Integer Overflow or Wraparound in publify/publify
Priority HIGH 76CWE-190Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-190 and the CVSS impact.
Summary
Integer Overflow or Wraparound in GitHub repository publify/publify prior to 9.2.10.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.30778 98th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed publify/publify (publify): 9.2.10publify_core (RubyGems): 9.2.10
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| publify | publify/publify | before 9.2.10 | 9.2.10 | Patch available | CNA |
| — | publify_core (RubyGems) | before 9.2.10 | 9.2.10 | Patch available | GHSA-rc42-jghf-vr8f |
- publify/publify Vendorpublify Affected before 9.2.10 Fixed in 9.2.10 Patch available CNA
- publify_core (RubyGems) Vendor— Affected before 9.2.10 Fixed in 9.2.10 Patch available GHSA-rc42-jghf-vr8f
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:publify_project:publify:*:*:*:*:*:*:*:* | before 9.2.10 | Vulnerable | publify_core |
- cpe:2.3:a:publify_project:publify:*:*:*:*:*:*:*:* Versions before 9.2.10 Vulnerable ·publify_core
Remediation
- Fix · CNA publify/publify (publify) Fixed in 9.2.10
- Fix · GHSA-rc42-jghf-vr8f publify_core (RubyGems) Fixed in 9.2.10 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
publify/publify 9.2.10
3 records Highest priority Priority HIGH 2 HIGH, 1 MEDIUM
Other records, highest priority first
- TI-2023-00284 Improper Input Validation in publify/publifyPriority HIGH 76
- TI-2022-02609 Insecure Storage of Sensitive Information in publify/publifyPriority MEDIUM 62
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1812
- 2026-10-03 Alias added: GHSA-rc42-jghf-vr8f
References
More publify vulnerabilities
- TI-2023-00284 Improper Input Validation in publify/publify CVSS 3.1CRITICAL 9.8
- TI-2023-00540 Weak Password Requirements in publify/publify CVSS 3.1MEDIUM 6.5
- TI-2022-02609 Insecure Storage of Sensitive Information in publify/publify CVSS 3.1MEDIUM 6.5
- TI-2024-26267 Publify Vulnerable To Cross-Site Scripting (XSS) Via Redirects Requiring User Interaction CVSS 4.0LOW 1.8
- TI-2022-00444 Business Logic Errors in publify/publify CVSS 3.1HIGH 7.5
- TI-2014-02574 Publify before 8.0.1 is vulnerable to a Denial of Service attack CVSS 3.1HIGH 7.5
Sources
- CVE-2022-1812 · CVE Program
- CVE-2022-1812 · NVD
- FIRST EPSS
- GHSA-rc42-jghf-vr8f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences