Read the docs
TI-2023-00540 Aliases CVE-2023-0569GHSA-g7gf-2rqw-5rwx

Weak Password Requirements in publify/publify

Priority MEDIUM 64CWE-521Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-521.

Summary

Weak Password Requirements in GitHub repository publify/publify prior to 9.2.10.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.007 53rd percentileScored 2026-11-07
Fix Fixed publify/publify (publify): 9.2.10publify_core (RubyGems): 9.2.10

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
publifypublify/publifybefore 9.2.109.2.10Patch availableCNA
—publify_core (RubyGems)before 9.2.109.2.10Patch availableGHSA-g7gf-2rqw-5rwx
  • publify/publify Vendorpublify Affected before 9.2.10 Fixed in 9.2.10 Patch available CNA
  • publify_core (RubyGems) Vendor— Affected before 9.2.10 Fixed in 9.2.10 Patch available GHSA-g7gf-2rqw-5rwx

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:publify_project:publify:*:*:*:*:*:*:*:*before 9.2.10Vulnerablepublify_core
  • cpe:2.3:a:publify_project:publify:*:*:*:*:*:*:*:* Versions before 9.2.10 Vulnerable ·publify_core

Remediation

  • Fix · CNA publify/publify (publify) Fixed in 9.2.10
  • Fix · GHSA-g7gf-2rqw-5rwx publify_core (RubyGems) Fixed in 9.2.10 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-0569
  2. 2026-10-03 Alias added: GHSA-g7gf-2rqw-5rwx

References

  • TI-2023-00284 Improper Input Validation in publify/publify CVSS 3.1CRITICAL 9.8
  • TI-2022-01678 Integer Overflow or Wraparound in publify/publify CVSS 3.1CRITICAL 9.8
  • TI-2022-02609 Insecure Storage of Sensitive Information in publify/publify CVSS 3.1MEDIUM 6.5
  • TI-2024-26267 Publify Vulnerable To Cross-Site Scripting (XSS) Via Redirects Requiring User Interaction CVSS 4.0LOW 1.8
  • TI-2022-00444 Business Logic Errors in publify/publify CVSS 3.1HIGH 7.5
  • TI-2014-02574 Publify before 8.0.1 is vulnerable to a Denial of Service attack CVSS 3.1HIGH 7.5
See all 11 →

Sources