Publify - Stored Cross-Site Scripting (XSS) in Editor
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
In Publify, versions v8.0 to v9.2.4 are vulnerable to stored XSS. A user with a “publisher” role is able to inject and execute arbitrary JavaScript code while creating a page/article.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| publify_core | publify_core | v8.0 and later; up to v9.2.4 | — | No fix listed | CNA |
| — | publify_core (RubyGems) | 8.0 to before 9.2.5 | 9.2.5 | Patch available | GHSA-wmh9-x28j-c6gr |
- publify_core Vendorpublify_core Affected v8.0 and later; up to v9.2.4 Fixed in — No fix listed CNA
- publify_core (RubyGems) Vendor— Affected 8.0 to before 9.2.5 Fixed in 9.2.5 Patch available GHSA-wmh9-x28j-c6gr
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:publify_project:publify:*:*:*:*:*:*:*:* | 8.0 – 9.2.4 | Vulnerable | publify_core |
- cpe:2.3:a:publify_project:publify:*:*:*:*:*:*:*:* Versions 8.0 – 9.2.4 Vulnerable ·publify_core
Remediation
- Fix · GHSA-wmh9-x28j-c6gr publify_core (RubyGems) Fixed in 9.2.5 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
publify_core unspecified
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2021-07981 Publify - Stored Cross-Site Scripting (XSS) due to Unrestricted File UploadPriority MEDIUM 58
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25974
- 2026-10-03 Alias added: GHSA-wmh9-x28j-c6gr
References
More publify_core Publify vulnerabilities
- TI-2023-00284 Improper Input Validation in publify/publify CVSS 3.1CRITICAL 9.8
- TI-2022-01678 Integer Overflow or Wraparound in publify/publify CVSS 3.1CRITICAL 9.8
- TI-2021-07979 Publify - Improper Authorization Leads to Guest Signup Restriction Bypass CVSS 3.1MEDIUM 6.5
- TI-2023-00540 Weak Password Requirements in publify/publify CVSS 3.1MEDIUM 6.5
- TI-2022-02609 Insecure Storage of Sensitive Information in publify/publify CVSS 3.1MEDIUM 6.5
- TI-2021-07981 Publify - Stored Cross-Site Scripting (XSS) due to Unrestricted File Upload CVSS 3.1MEDIUM 5.4
Sources
- CVE-2021-25974 · CVE Program
- CVE-2021-25974 · NVD
- FIRST EPSS
- GHSA-wmh9-x28j-c6gr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences