XSS in contact tracking and page hits report
Priority LOW 32CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Prior to this patch, a stored XSS vulnerability existed in the contact tracking and page hits report.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00291 21st percentileScored 2026-11-07
Fix Fixed Mautic (Mautic): < 4.4.13, < 5.1.1mautic/core-lib (Packagist): 4.4.13, 5.1.1+1 more product
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mautic | Mautic | >= 1.0.0-beta4 to before < 4.4.13; >= 5.0.0 to before < 5.1.1 | < 4.4.13, < 5.1.1 | Patch available | CNA |
| — | mautic/core-lib (Packagist) | 1.0.0-beta4 to before 4.4.13 | 4.4.13 | Patch available | GHSA-xpc5-rr39-v8v2 |
| — | mautic/core-lib (Packagist) | 5.0.0-alpha to before 5.1.1 | 5.1.1 | Patch available | GHSA-xpc5-rr39-v8v2 |
| — | mautic/core (Packagist) | 1.0.0-beta4 to before 4.4.13 | 4.4.13 | Patch available | GHSA-xpc5-rr39-v8v2 |
| — | mautic/core (Packagist) | 5.0.0-alpha to before 5.1.1 | 5.1.1 | Patch available | GHSA-xpc5-rr39-v8v2 |
- Mautic VendorMautic Affected >= 1.0.0-beta4 to before < 4.4.13; >= 5.0.0 to before < 5.1.1 Fixed in < 4.4.13, < 5.1.1 Patch available CNA
- mautic/core-lib (Packagist) Vendor— Affected 1.0.0-beta4 to before 4.4.13 Fixed in 4.4.13 Patch available GHSA-xpc5-rr39-v8v2
- mautic/core-lib (Packagist) Vendor— Affected 5.0.0-alpha to before 5.1.1 Fixed in 5.1.1 Patch available GHSA-xpc5-rr39-v8v2
- mautic/core (Packagist) Vendor— Affected 1.0.0-beta4 to before 4.4.13 Fixed in 4.4.13 Patch available GHSA-xpc5-rr39-v8v2
- mautic/core (Packagist) Vendor— Affected 5.0.0-alpha to before 5.1.1 Fixed in 5.1.1 Patch available GHSA-xpc5-rr39-v8v2
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:acquia:mautic:*:*:*:*:*:*:*:* | after 1.0.0, before 4.4.13; 5.0.0 to before 5.1.1 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:-:*:*:*:*:*:* | 1.0.0 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:beta4:*:*:*:*:*:* | 1.0.0 beta4 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:rc1:*:*:*:*:*:* | 1.0.0 rc1 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:rc2:*:*:*:*:*:* | 1.0.0 rc2 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:rc3:*:*:*:*:*:* | 1.0.0 rc3 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:rc4:*:*:*:*:*:* | 1.0.0 rc4 | Vulnerable | Acquia |
- cpe:2.3:a:acquia:mautic:*:*:*:*:*:*:*:* Versions after 1.0.0, before 4.4.13; 5.0.0 to before 5.1.1 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:-:*:*:*:*:*:* Versions 1.0.0 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:beta4:*:*:*:*:*:* Versions 1.0.0 beta4 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:rc1:*:*:*:*:*:* Versions 1.0.0 rc1 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:rc2:*:*:*:*:*:* Versions 1.0.0 rc2 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:rc3:*:*:*:*:*:* Versions 1.0.0 rc3 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:rc4:*:*:*:*:*:* Versions 1.0.0 rc4 Vulnerable ·Acquia
Remediation
- Fix · CNA Mautic (Mautic) Fixed in < 4.4.13, < 5.1.1
- Fix · GHSA-xpc5-rr39-v8v2 mautic/core-lib (Packagist) Fixed in 4.4.13 Advisory →
- Fix · GHSA-xpc5-rr39-v8v2 mautic/core-lib (Packagist) Fixed in 5.1.1 Advisory →
- Fix · GHSA-xpc5-rr39-v8v2 mautic/core (Packagist) Fixed in 4.4.13 Advisory →
- Fix · GHSA-xpc5-rr39-v8v2 mautic/core (Packagist) Fixed in 5.1.1 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Mautic < 4.4.13, < 5.1.1
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2022-09341 Improper Access Control in UI upgrade processPriority LOW 31
- TI-2024-31434 XSS in contact/company tracking (no authentication)Priority LOW 27
- TI-2024-31440 Cross-site Scripting (XSS) - stored (edit form HTML field)Priority LOW 21
Timeline
- 2026-10-02 Threatist record created from CVE-2021-27917
- 2026-10-03 Alias added: GHSA-xpc5-rr39-v8v2
References
Advisory 2
More Mautic vulnerabilities
- TI-2022-09344 Cross-site scripting in Mautic CVSS 3.1CRITICAL 9.6
- TI-2024-02543 Predictable Page Indexing Might Lead to Sensitive Data Exposure in Mautic CVSS 3.1MEDIUM 5.3
- TI-2024-02544 Improper Access Control Issues Lead to Sensitive Data Exposure in Mautic CVSS 3.1MEDIUM 5.4
- TI-2024-03218 Improper Access Control Leads to Server-Side Request Forgery in Mautic CVSS 3.1MEDIUM 5.0
- TI-2024-31435 Remote Code Execution & File Deletion in Asset Uploads CVSS 3.1CRITICAL 9.9
- TI-2018-05847 Mautic before 2.13.0 allows CSV injection. CVSS 3.0CRITICAL 9.8
Sources
- CVE-2021-27917 · CVE Program
- CVE-2021-27917 · NVD
- FIRST EPSS
- GHSA-xpc5-rr39-v8v2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences