Cross-site Scripting (XSS) - stored (edit form HTML field)
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
With access to edit a Mautic form, the attacker can add Cross-Site Scripting stored in the html filed. This could be used to steal sensitive information from the user's current session.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mautic | Mautic | >= 1.0.0 to before < 4.4.13; >= 5.0.0 to before < 5.1.1 | < 4.4.13, < 5.1.1 | Patch available | CNA |
| — | mautic/core (Packagist) | 5.0.0-alpha to before 5.1.1 | 5.1.1 | Patch available | GHSA-xv68-rrmw-9xwf |
| — | mautic/core (Packagist) | 1.0.0-beta to before 4.4.13 | 4.4.13 | Patch available | GHSA-xv68-rrmw-9xwf |
| — | mautic/core-lib (Packagist) | 5.0.0-alpha to before 5.1.1 | 5.1.1 | Patch available | GHSA-xv68-rrmw-9xwf |
| — | mautic/core-lib (Packagist) | 1.0.0-beta to before 4.4.13 | 4.4.13 | Patch available | GHSA-xv68-rrmw-9xwf |
- Mautic VendorMautic Affected >= 1.0.0 to before < 4.4.13; >= 5.0.0 to before < 5.1.1 Fixed in < 4.4.13, < 5.1.1 Patch available CNA
- mautic/core (Packagist) Vendor— Affected 5.0.0-alpha to before 5.1.1 Fixed in 5.1.1 Patch available GHSA-xv68-rrmw-9xwf
- mautic/core (Packagist) Vendor— Affected 1.0.0-beta to before 4.4.13 Fixed in 4.4.13 Patch available GHSA-xv68-rrmw-9xwf
- mautic/core-lib (Packagist) Vendor— Affected 5.0.0-alpha to before 5.1.1 Fixed in 5.1.1 Patch available GHSA-xv68-rrmw-9xwf
- mautic/core-lib (Packagist) Vendor— Affected 1.0.0-beta to before 4.4.13 Fixed in 4.4.13 Patch available GHSA-xv68-rrmw-9xwf
Remediation
- Fix · CNA Mautic (Mautic) Fixed in < 4.4.13, < 5.1.1
- Fix · GHSA-xv68-rrmw-9xwf mautic/core (Packagist) Fixed in 5.1.1 Advisory →
- Fix · GHSA-xv68-rrmw-9xwf mautic/core (Packagist) Fixed in 4.4.13 Advisory →
- Fix · GHSA-xv68-rrmw-9xwf mautic/core-lib (Packagist) Fixed in 5.1.1 Advisory →
- Fix · GHSA-xv68-rrmw-9xwf mautic/core-lib (Packagist) Fixed in 4.4.13 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Mautic < 4.4.13, < 5.1.1
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2021-09252 XSS in contact tracking and page hits reportPriority LOW 32
- TI-2022-09341 Improper Access Control in UI upgrade processPriority LOW 31
- TI-2024-31434 XSS in contact/company tracking (no authentication)Priority LOW 27
Timeline
- 2026-10-02 Threatist record created from CVE-2024-47058
- 2026-10-03 Alias added: GHSA-xv68-rrmw-9xwf
References
Advisory 2
More Mautic vulnerabilities
- TI-2022-09344 Cross-site scripting in Mautic CVSS 3.1CRITICAL 9.6
- TI-2024-02543 Predictable Page Indexing Might Lead to Sensitive Data Exposure in Mautic CVSS 3.1MEDIUM 5.3
- TI-2024-02544 Improper Access Control Issues Lead to Sensitive Data Exposure in Mautic CVSS 3.1MEDIUM 5.4
- TI-2024-03218 Improper Access Control Leads to Server-Side Request Forgery in Mautic CVSS 3.1MEDIUM 5.0
- TI-2024-31435 Remote Code Execution & File Deletion in Asset Uploads CVSS 3.1CRITICAL 9.9
- TI-2018-05847 Mautic before 2.13.0 allows CSV injection. CVSS 3.0CRITICAL 9.8
Sources
- CVE-2024-47058 · CVE Program
- CVE-2024-47058 · NVD
- FIRST EPSS
- GHSA-xv68-rrmw-9xwf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences