XSS vulnerability on Explore page
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Apache Superset up to and including 1.1 does not sanitize titles correctly on the Explore page. This allows an attacker with Explore access to save a chart with a malicious title, injecting html (including scripts) into the page.
Why it matters now
EPSS 0.01655 76th percentileScored 2026-11-07
Fix Fixed apache-superset (PyPI): 1.2.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Superset | up to 1.1 | — | No fix listed | CNA |
| — | apache-superset (PyPI) | before 1.2.0 | 1.2.0 | Patch available | GHSA-f8vc-f28w-x9c9 |
- Apache Superset VendorApache Affected up to 1.1 Fixed in — No fix listed CNA
- apache-superset (PyPI) Vendor— Affected before 1.2.0 Fixed in 1.2.0 Patch available GHSA-f8vc-f28w-x9c9
Remediation
- Fix · GHSA-f8vc-f28w-x9c9 apache-superset (PyPI) Fixed in 1.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-32609
- 2026-10-03 Alias added: GHSA-f8vc-f28w-x9c9
References
Advisory 3
More Apache Superset vulnerabilities
- TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
- TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
- TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
- TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
- TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-32609 · CVE Program
- CVE-2021-32609 · NVD
- FIRST EPSS
- GHSA-f8vc-f28w-x9c9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences