Reflected XSS from the callback handler's error query parameter
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before and including `1.4.1` are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the `error` query parameter which is then processed by the callback handler as an error message. You are affected by this vulnerability if you are using `@auth0/nextjs-auth0` version `1.4.1` or lower **unless** you are using custom error handling that does not return the error message in an HTML response. Upgrade to version `1.4.1` to resolve. The fix adds basic HTML escaping to the error message and it should not impact your users.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| auth0 | nextjs-auth0 | before 1.4.2 | 1.4.2 | Patch available | CNA |
| — | @auth0/nextjs-auth0 (npm) | before 1.4.2 | 1.4.2 | Patch available | GHSA-954c-jjx6-cxv7 |
- nextjs-auth0 Vendorauth0 Affected before 1.4.2 Fixed in 1.4.2 Patch available CNA
- @auth0/nextjs-auth0 (npm) Vendor— Affected before 1.4.2 Fixed in 1.4.2 Patch available GHSA-954c-jjx6-cxv7
Remediation
- Fix · CNA nextjs-auth0 (auth0) Fixed in 1.4.2
- Fix · GHSA-954c-jjx6-cxv7 @auth0/nextjs-auth0 (npm) Fixed in 1.4.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-32702
- 2026-10-03 Alias added: GHSA-954c-jjx6-cxv7
References
Advisory 2
More auth0 Nextjs-auth0 vulnerabilities
- TI-2021-19618 Open redirect in nextjs-auth0 CVSS 3.1MEDIUM 6.4
- TI-2025-41412 Auth0 Next.js SDK has Improper Validation of Query Parameters CVSS 3.1MEDIUM 5.7
- TI-2026-28970 Auth0 Next.js SDK has Improper Proxy Cache Lookup CVSS 3.1MEDIUM 5.4
- TI-2025-41249 Auth0 Next.js SDK has Improper Request Caching Lookup CVSS 3.1MEDIUM 5.4
Sources
- CVE-2021-32702 · CVE Program
- CVE-2021-32702 · NVD
- FIRST EPSS
- GHSA-954c-jjx6-cxv7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences