Auth0 Next.js SDK has Improper Proxy Cache Lookup
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In versions 4.12.0 through 4.17.1, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Users are affected if their project uses both the vulnerable versions and the proxy handler /me/* and /my-org/* with DPoP enabled. This issue has been fixed in version 4.18.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| auth0 | nextjs-auth0 | 4.12.0 to before 4.18.0 | 4.18.0 | Patch available | CNA |
| — | @auth0/nextjs-auth0 (npm) | 4.12.0 to before 4.18.0 | 4.18.0 | Patch available | GHSA-xq8m-7c5p-c2r6 |
- nextjs-auth0 Vendorauth0 Affected 4.12.0 to before 4.18.0 Fixed in 4.18.0 Patch available CNA
- @auth0/nextjs-auth0 (npm) Vendor— Affected 4.12.0 to before 4.18.0 Fixed in 4.18.0 Patch available GHSA-xq8m-7c5p-c2r6
Remediation
- Fix · CNA nextjs-auth0 (auth0) Fixed in 4.18.0
- Fix · GHSA-xq8m-7c5p-c2r6 @auth0/nextjs-auth0 (npm) Fixed in 4.18.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-40155
- 2026-10-03 Alias added: GHSA-xq8m-7c5p-c2r6
References
Advisory 2
More auth0 Nextjs-auth0 vulnerabilities
- TI-2021-12370 Reflected XSS from the callback handler's error query parameter CVSS 3.1HIGH 8.0
- TI-2021-19618 Open redirect in nextjs-auth0 CVSS 3.1MEDIUM 6.4
- TI-2025-41412 Auth0 Next.js SDK has Improper Validation of Query Parameters CVSS 3.1MEDIUM 5.7
- TI-2025-41249 Auth0 Next.js SDK has Improper Request Caching Lookup CVSS 3.1MEDIUM 5.4
Sources
- CVE-2026-40155 · CVE Program
- CVE-2026-40155 · NVD
- FIRST EPSS
- GHSA-xq8m-7c5p-c2r6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences