Read the docs
TI-2025-41249 Aliases CVE-2025-67490GHSA-wcgj-f865-c7j7

Auth0 Next.js SDK has Improper Request Caching Lookup

Priority LOW 24CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
High
Impact type
Security bypass
Confidentiality · integrity · availability
High · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.

Summary

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. When using versions 4.11.0 through 4.11.2 and 4.12.0, simultaneous requests on the same client may result in improper lookups in the TokenRequestCache for the request results. This issue is fixed in versions 4.11.2 and 4.12.1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00202 10th percentileScored 2026-11-07
Fix Fixed nextjs-auth0 (auth0): 4.12.1, 4.11.2@auth0/nextjs-auth0 (npm): 4.11.2, 4.12.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
auth0nextjs-auth04.12.0 to before 4.12.1; 4.11.0 to before 4.11.24.12.1, 4.11.2Patch availableCNA
—@auth0/nextjs-auth0 (npm)4.11.0 to before 4.11.24.11.2Patch availableGHSA-wcgj-f865-c7j7
—@auth0/nextjs-auth0 (npm)4.12.0 to before 4.12.14.12.1Patch availableGHSA-wcgj-f865-c7j7
  • nextjs-auth0 Vendorauth0 Affected 4.12.0 to before 4.12.1; 4.11.0 to before 4.11.2 Fixed in 4.12.1, 4.11.2 Patch available CNA
  • @auth0/nextjs-auth0 (npm) Vendor— Affected 4.11.0 to before 4.11.2 Fixed in 4.11.2 Patch available GHSA-wcgj-f865-c7j7
  • @auth0/nextjs-auth0 (npm) Vendor— Affected 4.12.0 to before 4.12.1 Fixed in 4.12.1 Patch available GHSA-wcgj-f865-c7j7

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:auth0:nextjs-auth0:4.11.0:*:*:*:*:node.js:*:*4.11.0Vulnerableauth0
cpe:2.3:a:auth0:nextjs-auth0:4.11.1:*:*:*:*:node.js:*:*4.11.1Vulnerableauth0
cpe:2.3:a:auth0:nextjs-auth0:4.12.0:*:*:*:*:node.js:*:*4.12.0Vulnerableauth0
  • cpe:2.3:a:auth0:nextjs-auth0:4.11.0:*:*:*:*:node.js:*:* Versions 4.11.0 Vulnerable ·auth0
  • cpe:2.3:a:auth0:nextjs-auth0:4.11.1:*:*:*:*:node.js:*:* Versions 4.11.1 Vulnerable ·auth0
  • cpe:2.3:a:auth0:nextjs-auth0:4.12.0:*:*:*:*:node.js:*:* Versions 4.12.0 Vulnerable ·auth0

Remediation

  • Fix · CNA nextjs-auth0 (auth0) Fixed in 4.12.1, 4.11.2
  • Fix · GHSA-wcgj-f865-c7j7 @auth0/nextjs-auth0 (npm) Fixed in 4.11.2 Advisory →
  • Fix · GHSA-wcgj-f865-c7j7 @auth0/nextjs-auth0 (npm) Fixed in 4.12.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-67490
  2. 2026-10-03 Alias added: GHSA-wcgj-f865-c7j7

References

  • TI-2021-12370 Reflected XSS from the callback handler's error query parameter CVSS 3.1HIGH 8.0
  • TI-2021-19618 Open redirect in nextjs-auth0 CVSS 3.1MEDIUM 6.4
  • TI-2025-41412 Auth0 Next.js SDK has Improper Validation of Query Parameters CVSS 3.1MEDIUM 5.7
  • TI-2026-28970 Auth0 Next.js SDK has Improper Proxy Cache Lookup CVSS 3.1MEDIUM 5.4

Sources