HTML injection in Jupyter Notebook and JupyterLab leading to DOM Clobbering
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
jupyterlab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. This vulnerability depends on user interaction by opening a malicious notebook with Markdown cells, or Markdown file using JupyterLab preview feature. A malicious user can access any data that the attacked user has access to as well as perform arbitrary requests acting as the attacked user. JupyterLab v3.6.8, v4.2.5 and Jupyter Notebook v7.2.2 have been patched to resolve this issue. Users are advised to upgrade. There is no workaround for the underlying DOM Clobbering susceptibility. However, select plugins can be disabled on deployments which cannot update in a timely fashion to minimise the risk. These are: 1. `@jupyterlab/mathjax-extension:plugin` - users will loose ability to preview mathematical equations. 2. `@jupyterlab/markdownviewer-extension:plugin` - users will loose ability to open Markdown previews. 3. `@jupyterlab/mathjax2-extension:plugin` (if installed with optional `jupyterlab-mathjax2` package) - an older version of the mathjax plugin for JupyterLab 4.x. To disable these extensions run: ```jupyter labextension disable @jupyterlab/markdownviewer-extension:plugin && jupyter labextension disable @jupyterlab/mathjax-extension:plugin && jupyter labextension disable @jupyterlab/mathjax2-extension:plugin ``` in bash.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jupyterlab | jupyterlab | notebook: >= 7.0.0, <= 7.2.2; jupyterlab: >= 4.0.0, < 4.2.5; jupyterlab: < 3.6.8 | — | No fix listed | CNA |
| — | jupyterlab (PyPI) | before 3.6.8 | 3.6.8 | Patch available | GHSA-9q39-rmj3-p4r2 |
| — | notebook (PyPI) | 7.0.0 to before 7.2.2 | 7.2.2 | Patch available | GHSA-9q39-rmj3-p4r2 |
| — | jupyterlab (PyPI) | 4.0.0 to before 4.2.5 | 4.2.5 | Patch available | GHSA-9q39-rmj3-p4r2 |
- jupyterlab Vendorjupyterlab Affected notebook: >= 7.0.0, <= 7.2.2; jupyterlab: >= 4.0.0, < 4.2.5; jupyterlab: < 3.6.8 Fixed in — No fix listed CNA
- jupyterlab (PyPI) Vendor— Affected before 3.6.8 Fixed in 3.6.8 Patch available GHSA-9q39-rmj3-p4r2
- notebook (PyPI) Vendor— Affected 7.0.0 to before 7.2.2 Fixed in 7.2.2 Patch available GHSA-9q39-rmj3-p4r2
- jupyterlab (PyPI) Vendor— Affected 4.0.0 to before 4.2.5 Fixed in 4.2.5 Patch available GHSA-9q39-rmj3-p4r2
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jupyter:jupyterlab:*:*:*:*:*:*:*:* | before 3.6.8; 4.0.0 to before 4.2.5 | Vulnerable | jupyterlab |
| cpe:2.3:a:jupyter:notebook:*:*:*:*:*:*:*:* | 7.0.0 to before 7.2.2 | Vulnerable | jupyterlab |
- cpe:2.3:a:jupyter:jupyterlab:*:*:*:*:*:*:*:* Versions before 3.6.8; 4.0.0 to before 4.2.5 Vulnerable ·jupyterlab
- cpe:2.3:a:jupyter:notebook:*:*:*:*:*:*:*:* Versions 7.0.0 to before 7.2.2 Vulnerable ·jupyterlab
Remediation
- Fix · GHSA-9q39-rmj3-p4r2 jupyterlab (PyPI) Fixed in 3.6.8 Advisory →
- Fix · GHSA-9q39-rmj3-p4r2 notebook (PyPI) Fixed in 7.2.2 Advisory →
- Fix · GHSA-9q39-rmj3-p4r2 jupyterlab (PyPI) Fixed in 4.2.5 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-43805
- 2026-10-03 Alias added: GHSA-9q39-rmj3-p4r2
References
Advisory 2
More Jupyterlab vulnerabilities
- TI-2024-26623 Remote Code Execution (RCE) vulnerability in jupyterlab extension template `update-integration-tests` GitHub Action CVSS 3.1CRITICAL 10.0
- TI-2026-30579 Improper input validation in jupyterlab CVSS 3.1HIGH 8.8
- TI-2021-12463 JupyterLab: XSS due to lack of sanitization of the action attribute of an html <form> CVSS 3.1CRITICAL 9.6
- TI-2026-30837 jupyterlab: Command linker attributes in HTML enable one-click command execution from untrusted content CVSS 4.0HIGH 8.6
- TI-2024-14994 Potential authentication and CSRF tokens leak in JupyterLab CVSS 3.1HIGH 7.6
- TI-2024-14993 Stored cross site scripting in Markdown Preview in JupyterLab CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-43805 · CVE Program
- CVE-2024-43805 · NVD
- FIRST EPSS
- GHSA-9q39-rmj3-p4r2 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-43805 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences