LearnPress < 4.1.6 - Reflected Cross-Site Scripting
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The LearnPress WordPress plugin before 4.1.6 does not sanitise and escape the lp-dismiss-notice before outputting it back via the lp_background_single_email AJAX action, leading to a Reflected Cross-Site Scripting
Why it matters now
EPSS 0.01944 80th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed LearnPress – WordPress LMS Plugin (Unknown): 4.1.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | LearnPress – WordPress LMS Plugin | 4.1.6 to before 4.1.6 | 4.1.6 | Patch available | CNA |
- LearnPress – WordPress LMS Plugin VendorUnknown Affected 4.1.6 to before 4.1.6 Fixed in 4.1.6 Patch available CNA
Remediation
- Fix · CNA LearnPress – WordPress LMS Plugin (Unknown) Fixed in 4.1.6
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0271
- 2026-10-03 Alias added: GHSA-g358-gf2c-r5f8
References
More ThimPress Learnpress vulnerabilities
- TI-2024-07900 LearnPress – WordPress LMS Plugin <= 4.2.7 - Unauthenticated SQL Injection via 'c_only_fields' CVSS 3.1CRITICAL 10.0
- TI-2023-06018 LearnPress <= 4.2.5.7 - Unauthenticated SQL Injection via order_by CVSS 3.1CRITICAL 9.8
- TI-2024-04124 LearnPress – WordPress LMS Plugin <= 4.2.6.5 - Unauthenticated Time-Based SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2023-18355 WordPress LearnPress plugin <= 4.2.3 - Authenticated Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2022-03105 LearnPress < 4.1.7.2 - Unauthenticated PHP Object Injection via REST API CVSS 3.1HIGH 8.1
- TI-2020-04911 LearnPress Wordpress plugin version prior and including 3.2.6.7 is vulnerable to SQL Injection CVSS 3.1HIGH 8.8
Sources
- CVE-2022-0271 · CVE Program
- CVE-2022-0271 · NVD
- FIRST EPSS
- GHSA-g358-gf2c-r5f8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences