LearnPress < 4.1.5 - Arbitrary Image Renaming
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-327.
Summary
Users of the LearnPress WordPress plugin before 4.1.5 can upload an image as a profile avatar after the registration. After this process the user crops and saves the image. Then a "POST" request that contains user supplied name of the image is sent to the server for renaming and cropping of the image. As a result of this request, the name of the user-supplied image is changed with a MD5 value. This process can be conducted only when type of the image is JPG or PNG. An attacker can use this vulnerability in order to rename an arbitrary image file. By doing this, they could destroy the design of the web site.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | LearnPress | before 4.1.5 | 4.1.5 | Patch available | CNA |
- LearnPress VendorUnknown Affected before 4.1.5 Fixed in 4.1.5 Patch available CNA
Remediation
- Fix · CNA LearnPress (Unknown) Fixed in 4.1.5
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0377
- 2026-10-03 Alias added: GHSA-6mqq-rw6c-7747
References
More ThimPress Learnpress vulnerabilities
- TI-2024-07900 LearnPress – WordPress LMS Plugin <= 4.2.7 - Unauthenticated SQL Injection via 'c_only_fields' CVSS 3.1CRITICAL 10.0
- TI-2023-06018 LearnPress <= 4.2.5.7 - Unauthenticated SQL Injection via order_by CVSS 3.1CRITICAL 9.8
- TI-2024-04124 LearnPress – WordPress LMS Plugin <= 4.2.6.5 - Unauthenticated Time-Based SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2023-18355 WordPress LearnPress plugin <= 4.2.3 - Authenticated Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2022-03105 LearnPress < 4.1.7.2 - Unauthenticated PHP Object Injection via REST API CVSS 3.1HIGH 8.1
- TI-2020-04911 LearnPress Wordpress plugin version prior and including 3.2.6.7 is vulnerable to SQL Injection CVSS 3.1HIGH 8.8
Sources
- CVE-2022-0377 · CVE Program
- CVE-2022-0377 · NVD
- FIRST EPSS
- GHSA-6mqq-rw6c-7747 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences