Popup Builder < 4.1.1 - SQL Injection to Reflected Cross-Site Scripting
Priority HIGH 71CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
The Popup Builder WordPress plugin before 4.1.1 does not sanitise and escape the sgpb-subscription-popup-id parameter before using it in a SQL statement in the All Subscribers admin dashboard, leading to a SQL injection, which could also be used to perform Reflected Cross-Site Scripting attack against a logged in admin opening a malicious link
Why it matters now
EPSS 0.43807 98th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Popup Builder – Create highly converting, mobile friendly marketing popups. (Unknown): 4.1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Popup Builder – Create highly converting, mobile friendly marketing popups. | 4.1.1 to before 4.1.1 | 4.1.1 | Patch available | CNA |
- Popup Builder – Create highly converting, mobile friendly marketing popups. VendorUnknown Affected 4.1.1 to before 4.1.1 Fixed in 4.1.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sygnoos:popup_builder:*:*:*:*:*:wordpress:*:* | before 4.1.1 | Vulnerable | popupbuilder |
- cpe:2.3:a:sygnoos:popup_builder:*:*:*:*:*:wordpress:*:* Versions before 4.1.1 Vulnerable ·popupbuilder
Remediation
- Fix · CNA Popup Builder – Create highly converting, mobile friendly marketing popups. (Unknown) Fixed in 4.1.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0479
- 2026-10-03 Alias added: GHSA-3m2q-xc74-xcj8
References
More popupbuilder Popup Builder vulnerabilities
- TI-2023-05777 popup-builder < 4.2.6 - Admin+ SSRF & File Read CVSS 3.1HIGH 7.5
- TI-2024-08748 Popup Builder < 4.3.5 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2020-07226 The Popup Builder plugin 2.2.8 through 2.6.7.6 for WordPress is vulnerable to SQL… CVSS 3.1CRITICAL 9.8
- TI-2019-10917 A SQL injection vulnerability exists in the Sygnoos Popup Builder plugin before 3.45 for… CVSS 3.1CRITICAL 9.8
- TI-2021-07360 Popup Builder < 4.0.7 - LFI to RCE CVSS 3.1HIGH 8.8
- TI-2024-02363 Popup Builder <= 4.3.6 - Sensitive Information Exposure via Imported Subscribers CSV File CVSS 3.1HIGH 7.5
Sources
- CVE-2022-0479 · CVE Program
- CVE-2022-0479 · NVD
- FIRST EPSS
- GHSA-3m2q-xc74-xcj8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences