Read the docs
TI-2023-05777 Aliases CVE-2023-6294GHSA-cc2p-f3qf-3fr6

popup-builder < 4.2.6 - Admin+ SSRF & File Read

Priority HIGH 66CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-22 and the CVSS impact.

Summary

The Popup Builder WordPress plugin before 4.2.6 does not validate a parameter before making a request to it, which could allow users with the administrator role to perform SSRF attack in Multisite WordPress configurations.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00812 57th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Popup Builder (Unknown): 4.2.6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPopup Builderbefore 4.2.64.2.6Patch availableCNA
  • Popup Builder VendorUnknown Affected before 4.2.6 Fixed in 4.2.6 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:sygnoos:popup_builder:*:*:*:*:*:wordpress:*:*before 4.2.6Vulnerablepopupbuilder
  • cpe:2.3:a:sygnoos:popup_builder:*:*:*:*:*:wordpress:*:* Versions before 4.2.6 Vulnerable ·popupbuilder

Remediation

  • Fix · CNA Popup Builder (Unknown) Fixed in 4.2.6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-6294
  2. 2026-10-03 Alias added: GHSA-cc2p-f3qf-3fr6

References

  • TI-2022-00402 Popup Builder < 4.1.1 - SQL Injection to Reflected Cross-Site Scripting CVSS 3.1CRITICAL 9.8
  • TI-2024-08748 Popup Builder < 4.3.5 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2020-07226 The Popup Builder plugin 2.2.8 through 2.6.7.6 for WordPress is vulnerable to SQL… CVSS 3.1CRITICAL 9.8
  • TI-2019-10917 A SQL injection vulnerability exists in the Sygnoos Popup Builder plugin before 3.45 for… CVSS 3.1CRITICAL 9.8
  • TI-2021-07360 Popup Builder < 4.0.7 - LFI to RCE CVSS 3.1HIGH 8.8
  • TI-2024-02363 Popup Builder <= 4.3.6 - Sensitive Information Exposure via Imported Subscribers CSV File CVSS 3.1HIGH 7.5
See all 17 →

Sources