Popup Builder < 4.0.7 - LFI to RCE
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The Popup Builder WordPress plugin before 4.0.7 does not validate and sanitise the sgpb_type parameter before using it in a require statement, leading to a Local File Inclusion issue. Furthermore, since the beginning of the string can be controlled, the issue can lead to RCE vulnerability via wrappers such as PHAR
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Popup Builder – Create highly converting, mobile friendly marketing popups. | 4.0.7 to before 4.0.7 | 4.0.7 | Patch available | CNA |
- Popup Builder – Create highly converting, mobile friendly marketing popups. VendorUnknown Affected 4.0.7 to before 4.0.7 Fixed in 4.0.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sygnoos:popup_builder:*:*:*:*:*:wordpress:*:* | before 4.0.7 | Vulnerable | popupbuilder |
- cpe:2.3:a:sygnoos:popup_builder:*:*:*:*:*:wordpress:*:* Versions before 4.0.7 Vulnerable ·popupbuilder
Remediation
- Fix · CNA Popup Builder – Create highly converting, mobile friendly marketing popups. (Unknown) Fixed in 4.0.7
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Popup Builder – Create highly converting, mobile friendly marketing popups. 4.0.7
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2022-00164 Popup Builder < 4.0.7 - Admin+ SQL InjectionPriority MEDIUM 40
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25082
- 2026-10-03 Alias added: GHSA-rgh6-hx6g-h7q7
References
More popupbuilder Popup Builder vulnerabilities
- TI-2022-00402 Popup Builder < 4.1.1 - SQL Injection to Reflected Cross-Site Scripting CVSS 3.1CRITICAL 9.8
- TI-2023-05777 popup-builder < 4.2.6 - Admin+ SSRF & File Read CVSS 3.1HIGH 7.5
- TI-2024-08748 Popup Builder < 4.3.5 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2020-07226 The Popup Builder plugin 2.2.8 through 2.6.7.6 for WordPress is vulnerable to SQL… CVSS 3.1CRITICAL 9.8
- TI-2019-10917 A SQL injection vulnerability exists in the Sygnoos Popup Builder plugin before 3.45 for… CVSS 3.1CRITICAL 9.8
- TI-2024-02363 Popup Builder <= 4.3.6 - Sensitive Information Exposure via Imported Subscribers CSV File CVSS 3.1HIGH 7.5
Sources
- CVE-2021-25082 · CVE Program
- CVE-2021-25082 · NVD
- FIRST EPSS
- GHSA-rgh6-hx6g-h7q7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences