Priority HIGH 71
The Popup Builder WordPress plugin before 4.1.1 does not sanitise and escape the sgpb-subscription-popup-id parameter before using it in a SQL statement in the All Subscribers admin dashboard, leading to a SQL injection,…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.43807 · Published 2022-03-28 · Fixed in 4.1.1 CWE-89
Priority HIGH 66
The Popup Builder WordPress plugin before 4.2.6 does not validate a parameter before making a request to it, which could allow users with the administrator role to perform SSRF attack in Multisite WordPress configuration…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00812 · Published 2024-02-12 · Fixed in 4.2.6 CWE-22
Priority MEDIUM 55
The Popup Builder WordPress plugin before 4.3.5 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilte…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00347 · Published 2024-12-12 · Fixed in 4.3.5 CWE-79
Priority MEDIUM 53
The Popup Builder plugin 2.2.8 through 2.6.7.6 for WordPress is vulnerable to SQL injection (in the sgImportPopups function in sg_popup_ajax.php) via PHP Deserialization on attacker-controlled data with the attachmentUrl…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.0856 · Published 2020-02-17 · No fix listed CWE-502
Priority MEDIUM 47
A SQL injection vulnerability exists in the Sygnoos Popup Builder plugin before 3.45 for WordPress.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.02727 · Published 2019-08-06 · No fix listed CWE-89
Priority MEDIUM 46
The Popup Builder WordPress plugin before 4.0.7 does not validate and sanitise the sgpb_type parameter before using it in a require statement, leading to a Local File Inclusion issue.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.05229 · Published 2022-02-21 · Fixed in 4.0.7 CWE-22
Priority MEDIUM 45
The Popup Builder – Create highly converting, mobile friendly marketing popups.
CVSS 3.1CRITICAL 9.1· Network · No auth · No interaction · EPSS 0.00394 · Published 2026-10-31 · No fix listed CWE-862
Priority MEDIUM 41
Deserialization of Untrusted Data vulnerability in Social Media Share Buttons By Sygnoos Social Media Share Buttons.This issue affects Social Media Share Buttons: from n/a through 2.1.0.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00672 · Published 2024-03-20 · No fix listed CWE-502
Priority MEDIUM 41
The Social Media Share Buttons plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 2.1.0 via deserialization of untrusted input through the attachmentUrl parameter.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00769 · Published 2024-03-16 · No fix listed CWE-502
Priority MEDIUM 40
The Popup Builder plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.3.6 via the Subscribers Import feature.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00564 · Published 2024-08-29 · No fix listed CWE-200
Priority MEDIUM 40
The Popup Builder WordPress plugin before 4.0.7 does not validate and properly escape the orderby and order parameters before using them in a SQL statement in the admin dashboard, which could allow high privilege users t…
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.05263 · Published 2022-02-21 · Fixed in 4.0.7 CWE-89
Priority LOW 36
The Popup Builder – Create highly converting, mobile friendly marketing popups.
CVSS 3.1HIGH 8.1· Network · Low privileges · No interaction · EPSS 0.00471 · Published 2024-06-15 · No fix listed CWE-862
Priority LOW 32
The Popup Builder plugin for WordPress is vulnerable to unauthorized modification of data and loss of data due to a missing capability check on all AJAX actions.
CVSS 3.1HIGH 7.4· Network · Low privileges · No interaction · EPSS 0.00271 · Published 2024-06-15 · No fix listed CWE-862
Priority LOW 31
The Popup Builder WordPress plugin before 4.2.3 does not prevent simple visitors from updating existing popups, and injecting raw JavaScript in them, which could lead to Stored XSS attacks.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01999 · Published 2024-01-01 · Fixed in 4.2.3 CWE-79
Priority LOW 30
The Popup Builder – Create highly converting, mobile friendly marketing popups.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00432 · Published 2026-02-19 · No fix listed CWE-1241
Priority LOW 30
An XSS vulnerability in the popup-builder plugin before 3.64.1 for WordPress allows remote attackers to inject arbitrary JavaScript into existing popups via an unsecured ajax action in com/classes/Ajax.php.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01421 · Published 2020-03-13 · No fix listed CWE-79
Priority LOW 30
The popup-builder plugin before 3.64.1 for WordPress allows information disclosure and settings modification, leading to in-scope privilege escalation via admin-post actions to com/classes/Actions.php.
CVSS 3.1MEDIUM 6.3· Network · Low privileges · No interaction · EPSS 0.01091 · Published 2020-03-13 · No fix listed CWE-200
Priority LOW 29
The "All Subscribers" setting page of Popup Builder was vulnerable to reflected Cross-Site Scripting.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00734 · Published 2021-04-05 · Fixed in 3.74 CWE-79
Priority LOW 28
The Popup Builder – Create highly converting, mobile friendly marketing popups.
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00299 · Published 2025-12-13 · No fix listed CWE-79
Priority LOW 28
The Popup Builder – Create highly converting, mobile friendly marketing popups.
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00267 · Published 2024-06-01 · No fix listed CWE-79
Priority LOW 25
Cross-Site Request Forgery (CSRF) vulnerability in Sygnoos Popup Builder plugin <= 4.1.11 at WordPress allows an attacker to update plugin settings.
CVSS 3.1MEDIUM 5.4· Network · No auth · User interaction · EPSS 0.0053 · Published 2022-07-22 · No fix listed CWE-352
Priority LOW 24
Cross-Site Request Forgery (CSRF) vulnerability in Sygnoos Popup Builder plugin <= 4.1.0 at WordPress leading to popup status change.
CVSS 3.1MEDIUM 5.4· Network · No auth · User interaction · EPSS 0.00331 · Published 2022-07-21 · No fix listed CWE-352
Priority LOW 23
The Popup Builder WordPress plugin before 4.1.11 does not escape and sanitize some settings, which could allow high privilege users to perform Stored Cross-Site Scripting attacks when the unfiltred_html is disallowed
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00588 · Published 2022-07-11 · Fixed in 4.1.11 CWE-79
Priority LOW 22
The Popup Builder WordPress plugin before 4.2.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilte…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00448 · Published 2023-09-25 · Fixed in 4.2.0