Unrestricted file upload in pgadmin
Priority LOW 31CWE-434Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-434.
Summary
A malicious, but authorised and authenticated user can construct an HTTP request using their existing CSRF token and session cookie to manually upload files to any location that the operating system user account under which pgAdmin is running has permission to write.
Why it matters now
EPSS 0.00968 62nd percentileScored 2026-11-07
Fix Fixed pgadmin4 (PyPI): 6.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | pgadmin | pgadmin 6.7 | — | No fix listed | CNA |
| — | pgadmin4 (PyPI) | before 6.7 | 6.7 | Patch available | GHSA-cr8c-972v-rmp3 |
- pgadmin Vendor— Affected pgadmin 6.7 Fixed in — No fix listed CNA
- pgadmin4 (PyPI) Vendor— Affected before 6.7 Fixed in 6.7 Patch available GHSA-cr8c-972v-rmp3
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:*:*:* | before 6.7 | Vulnerable | pgadmin.org |
- cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:*:*:* Versions before 6.7 Vulnerable ·pgadmin.org
Remediation
- Fix · GHSA-cr8c-972v-rmp3 pgadmin4 (PyPI) Fixed in 6.7 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0959
- 2026-10-03 Alias added: GHSA-cr8c-972v-rmp3
References
More pgadmin.org Pgadmin 4 vulnerabilities
- TI-2024-01901 Unsafe Deserialisation and Remote Code Execution by an Authenticated user in pgAdmin 4 CVSS 3.1CRITICAL 9.9
- TI-2024-02918 Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4 CVSS 3.1CRITICAL 9.8
- TI-2022-03867 Code injection in pgadmin4 CVSS 3.1HIGH 8.8
- TI-2026-06875 pgAdmin 4: Cross-user data access and shared-server privilege escalation in server mode CVSS 4.0CRITICAL 9.4
- TI-2025-02572 pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment CVSS 3.1CRITICAL 9.9
- TI-2023-00228 Path traversal in pgadmin CVSS 3.1MEDIUM 6.5
Sources
- CVE-2022-0959 · CVE Program
- CVE-2022-0959 · NVD
- FIRST EPSS
- GHSA-cr8c-972v-rmp3 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-0959 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences