Read the docs
TI-2022-01111 Aliases CVE-2022-1224GHSA-prm2-47w6-22x5

Improper Authorization in phpipam/phpipam

Priority LOW 31CWE-285Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-285.

Summary

Improper Authorization in GitHub repository phpipam/phpipam prior to 1.4.6.

Why it matters now

EPSS 0.01031 63rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed phpipam/phpipam (phpipam): 1.4.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
phpipamphpipam/phpipambefore 1.4.61.4.6Patch availableCNA
  • phpipam/phpipam Vendorphpipam Affected before 1.4.6 Fixed in 1.4.6 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:phpipam:phpipam:*:*:*:*:*:*:*:*before 1.4.6Vulnerablephpipam
  • cpe:2.3:a:phpipam:phpipam:*:*:*:*:*:*:*:* Versions before 1.4.6 Vulnerable ·phpipam

Remediation

  • Fix · CNA phpipam/phpipam (phpipam) Fixed in 1.4.6

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    phpipam/phpipam 1.4.6

    3 records Highest priority Priority LOW 3 LOW

    Other records, highest priority first

    • TI-2022-01112 Incorrect Privilege Assignment in phpipam/phpipamPriority LOW 31
    • TI-2022-01110 Incorrect Authorization in phpipam/phpipamPriority LOW 31

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-1224
  2. 2026-10-03 Alias added: GHSA-prm2-47w6-22x5

References

  • TI-2024-09932 Cookie without Secure attribute in phpipam/phpipam CVSS 3.1HIGH 7.5
  • TI-2023-22036 Phpipam before v1.5.2 was discovered to contain a LDAP injection vulnerability via the… CVSS 3.1HIGH 7.5
  • TI-2023-01145 SQL Injection in phpipam/phpipam CVSS 3.1HIGH 7.2
  • TI-2024-00724 Improper Restriction of Excessive Authentication Attempts in phpipam/phpipam CVSS 3.1MEDIUM 5.9
  • TI-2024-27603 phpipam 1.6 is vulnerable to Cross Site Scripting (XSS) via /app/admin/powerDNS/record-edit.php. CVSS 3.1HIGH 7.1
  • TI-2024-27600 phpipam 1.6 is vulnerable to Cross Site Scripting (XSS) via /app/admin/widgets/edit.php CVSS 3.1HIGH 7.1
See all 51 →

Sources