Cross-site Scripting (XSS) in phpipam/phpipam
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A Cross-Site Scripting (XSS) vulnerability in phpipam/phpipam versions prior to 1.4.7 allows attackers to execute arbitrary JavaScript code in the browser of a victim. This vulnerability affects the import Data set feature via a spreadsheet file upload. The affected endpoints include import-vlan-preview.php, import-subnets-preview.php, import-vrf-preview.php, import-ipaddr-preview.php, import-devtype-preview.php, import-devices-preview.php, and import-l2dom-preview.php. The vulnerability can be exploited by uploading a specially crafted spreadsheet file containing malicious JavaScript payloads, which are then executed in the context of the victim's browser. This can lead to defacement of websites, execution of malicious JavaScript code, stealing of user cookies, and unauthorized access to user accounts.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA phpipam/phpipam (phpipam) Fixed in 1.4.7
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1226
- 2026-10-03 Alias added: GHSA-fpg3-c7pp-9cgh
References
More Phpipam vulnerabilities
- TI-2024-09932 Cookie without Secure attribute in phpipam/phpipam CVSS 3.1HIGH 7.5
- TI-2023-22036 Phpipam before v1.5.2 was discovered to contain a LDAP injection vulnerability via the… CVSS 3.1HIGH 7.5
- TI-2023-01145 SQL Injection in phpipam/phpipam CVSS 3.1HIGH 7.2
- TI-2024-00724 Improper Restriction of Excessive Authentication Attempts in phpipam/phpipam CVSS 3.1MEDIUM 5.9
- TI-2024-27603 phpipam 1.6 is vulnerable to Cross Site Scripting (XSS) via /app/admin/powerDNS/record-edit.php. CVSS 3.1HIGH 7.1
- TI-2024-27600 phpipam 1.6 is vulnerable to Cross Site Scripting (XSS) via /app/admin/widgets/edit.php CVSS 3.1HIGH 7.1
Sources
- CVE-2022-1226 · CVE Program
- CVE-2022-1226 · NVD
- FIRST EPSS
- GHSA-fpg3-c7pp-9cgh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences