Bold Page Builder < 4.3.3 - Admin+ Stored Cross-Site Scripting
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Bold Page Builder WordPress plugin before 4.3.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed.
Why it matters now
EPSS 0.01115 66th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Bold Page Builder (Unknown): 4.3.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Bold Page Builder | 4.3.3 to before 4.3.3 | 4.3.3 | Patch available | CNA |
- Bold Page Builder VendorUnknown Affected 4.3.3 to before 4.3.3 Fixed in 4.3.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:bold-themes:bold_page_builder:*:*:*:*:*:wordpress:*:* | before 4.3.3 | Vulnerable | boldthemes |
- cpe:2.3:a:bold-themes:bold_page_builder:*:*:*:*:*:wordpress:*:* Versions before 4.3.3 Vulnerable ·boldthemes
Remediation
- Fix · CNA Bold Page Builder (Unknown) Fixed in 4.3.3
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2089
- 2026-10-03 Alias added: GHSA-73gj-q4pv-5fxr
References
More boldthemes Bold Page Builder vulnerabilities
- TI-2021-06863 Bold Page Builder < 3.1.6 - PHP Object Injection CVSS 3.1HIGH 8.8
- TI-2019-11888 The bold-page-builder plugin before 2.3.2 for WordPress has no protection against modifying settings and importing data. CVSS 3.0HIGH 7.5
- TI-2024-33850 WordPress Bold Page Builder plugin <= 5.1.3 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2024-35999 WordPress Bold Page Builder plugin <= 5.2.1 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-31709 WordPress Bold Page Builder plugin < 5.1.1 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-31616 WordPress Bold Page Builder plugin <= 5.1.1 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2022-2089 · CVE Program
- CVE-2022-2089 · NVD
- FIRST EPSS
- GHSA-73gj-q4pv-5fxr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences