Affiliates Manager < 2.9.14 - Admin+ Stored Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Affiliates Manager WordPress plugin before 2.9.14 does not sanitise and escape some of its settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Affiliates Manager | 2.9.14 to before 2.9.14 | 2.9.14 | Patch available | CNA |
- Affiliates Manager VendorUnknown Affected 2.9.14 to before 2.9.14 Fixed in 2.9.14 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wpaffiliatemanager:affiliates_manager:*:*:*:*:*:wordpress:*:* | before 2.9.14 | Vulnerable | wp.insider, wpaffiliatemgr |
- cpe:2.3:a:wpaffiliatemanager:affiliates_manager:*:*:*:*:*:wordpress:*:* Versions before 2.9.14 Vulnerable ·wp.insider, wpaffiliatemgr
Remediation
- Fix · CNA Affiliates Manager (Unknown) Fixed in 2.9.14
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Affiliates Manager 2.9.14
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2022-02593 Affiliates Manager < 2.9.14 - Affiliate CSV InjectionPriority LOW 37
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2799
- 2026-10-03 Alias added: GHSA-gg3w-9qrw-p79x
- 2026-10-04 EPSS moved to the 50th–90th percentile
References
More wp.insider, wpaffiliatemgr Affiliates Manager vulnerabilities
- TI-2023-28569 WordPress Affiliates Manager Plugin <= 2.9.31 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2019-11928 The affiliates-manager plugin before 2.6.6 for WordPress has CSRF. CVSS 3.0HIGH 8.8
- TI-2023-13448 WordPress Affiliates Manager Plugin <= 2.9.20 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2022-02593 Affiliates Manager < 2.9.14 - Affiliate CSV Injection CVSS 3.1HIGH 8.0
- TI-2021-07126 Affiliate Manager < 2.8.7 - Admin+ SQL injection CVSS 3.1HIGH 7.2
- TI-2021-07356 Affiliates Manager < 2.9.0 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-2799 · CVE Program
- CVE-2022-2799 · NVD
- FIRST EPSS
- GHSA-gg3w-9qrw-p79x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences