Read the docs
TI-2022-07698 Aliases CVE-2022-23646GHSA-fmvm-x8mv-47mj

Improper CSP in Image Optimization API for Next.js

Priority LOW 36CWE-451Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Spoofing
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-451.

Summary

Next.js is a React framework. Starting with version 10.0.0 and prior to version 12.1.0, Next.js is vulnerable to User Interface (UI) Misrepresentation of Critical Information. In order to be affected, the `next.config.js` file must have an `images.domains` array assigned and the image host assigned in `images.domains` must allow user-provided SVG. If the `next.config.js` file has `images.loader` assigned to something other than default, the instance is not affected. Version 12.1.0 contains a patch for this issue. As a workaround, change `next.config.js` to use a different `loader configuration` other than the default.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01795 78th percentileScored 2026-11-07
Fix Fixed next.js (vercel): 12.1.0next (npm): 12.1.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
vercelnext.js10.0.0 to before 12.1.012.1.0Patch availableCNA
—next (npm)10.0.0 to before 12.1.012.1.0Patch availableGHSA-fmvm-x8mv-47mj
  • next.js Vendorvercel Affected 10.0.0 to before 12.1.0 Fixed in 12.1.0 Patch available CNA
  • next (npm) Vendor— Affected 10.0.0 to before 12.1.0 Fixed in 12.1.0 Patch available GHSA-fmvm-x8mv-47mj

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*10.0.0 to before 12.1.0Vulnerablevercel
  • cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:* Versions 10.0.0 to before 12.1.0 Vulnerable ·vercel

Remediation

  • Fix · CNA next.js (vercel) Fixed in 12.1.0
  • Fix · GHSA-fmvm-x8mv-47mj next (npm) Fixed in 12.1.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-23646
  2. 2026-10-03 Alias added: GHSA-fmvm-x8mv-47mj

References

  • TI-2025-34861 Deserialization of untrusted data in Meta react-server-dom-webpack KEVCVSS 3.1CRITICAL 10.0
  • TI-2025-21309 Authorization Bypass in Next.js Middleware CVSS 3.1CRITICAL 9.1
  • TI-2025-34863 Deserialization of untrusted data in Meta react-server-dom-webpack CVSS 3.1HIGH 7.5
  • TI-2024-31371 Cache Poisoning in next.js CVSS 3.1HIGH 7.5
  • TI-2023-24914 Next.js before 13.4.20-canary.13 lacks a cache-control header and thus empty prefetch… CVSS 3.1HIGH 7.5
  • TI-2026-32490 Next.js: Server-side request forgery in applications using WebSocket upgrades CVSS 3.1HIGH 8.6
See all 62 →

Sources