Read the docs
TI-2022-08024 Aliases CVE-2022-24066GHSA-28xr-mwxg-3qc8

Command injection in simple-git

Priority MEDIUM 49CWE-88Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-88.

Summary

The package simple-git before 3.5.0 are vulnerable to Command Injection due to an incomplete fix of [CVE-2022-24433](https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-2421199) which only patches against the git fetch attack vector. A similar use of the --upload-pack feature of git is also supported for git clone, which the prior fix didn't cover.

Why it matters now

EPSS 0.03896 90th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed simple-git: 3.5.0simple-git (npm): 3.5.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—simple-gitbefore 3.5.03.5.0Patch availableCNA
—simple-git (npm)before 3.5.03.5.0Patch availableGHSA-28xr-mwxg-3qc8
  • simple-git Vendor— Affected before 3.5.0 Fixed in 3.5.0 Patch available CNA
  • simple-git (npm) Vendor— Affected before 3.5.0 Fixed in 3.5.0 Patch available GHSA-28xr-mwxg-3qc8

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:simple-git_project:simple-git:*:*:*:*:*:node.js:*:*before 3.5.0Vulnerablesteveukx
  • cpe:2.3:a:simple-git_project:simple-git:*:*:*:*:*:node.js:*:* Versions before 3.5.0 Vulnerable ·steveukx

Remediation

  • Fix · CNA simple-git Fixed in 3.5.0
  • Fix · GHSA-28xr-mwxg-3qc8 simple-git (npm) Fixed in 3.5.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-24066
  2. 2026-10-03 Alias added: GHSA-28xr-mwxg-3qc8
  3. 2026-10-11 EPSS moved to the 90th–95th percentile

References

  • TI-2026-22598 simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key that enables RCE CVSS 3.1CRITICAL 9.8
  • TI-2022-09464 Remote code execution (RCE) in simple-git CVSS 3.1CRITICAL 9.8
  • TI-2026-06084 Code injection in simple-git CVSS 4.0CRITICAL 9.2
  • TI-2022-09425 Code injection in simple-git CVSS 3.1CRITICAL 9.8
  • TI-2026-65515 simple-git allows command execution through unblocked Git configuration includes CVSS 3.1HIGH 8.1
  • TI-2026-22597 simple-git has Command Execution via Option-Parsing Bypass CVSS 3.1HIGH 8.1
See all 9 →

Sources