Read the docs

simple-git allows command execution through unblocked Git configuration includes

Priority HIGH 70CWE-77Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-77.

Summary

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 4.0.0, the default blockUnsafeOperationsPlugin does not completely reject configuration includes supplied through customArgs to git.clone(). The missing include.path classification permits Git to load an attacker-controlled configuration file, and the initial remediation does not cover includeIf.<condition>.path, allowing the same file-loading primitive through a conditional include. A loaded configuration can set an executable Git option such as core.sshCommand, which Git invokes during the clone operation with the privileges of the Node.js process. Exploitation requires the application to pass attacker-influenced custom arguments and requires an attacker-controlled file that the process can read. This issue is fixed in 4.0.0.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00464 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial git-js (steveukx): 4.0.0simple-git (npm): 4.0.0Red Hat: 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
steveukxgit-jsbefore 4.0.04.0.0Patch availableCNA
—simple-git (npm)before 4.0.04.0.0Patch availableGHSA-g4wm-2vf7-vfgr
  • git-js Vendorsteveukx Affected before 4.0.0 Fixed in 4.0.0 Patch available CNA
  • simple-git (npm) Vendor— Affected before 4.0.0 Fixed in 4.0.0 Patch available GHSA-g4wm-2vf7-vfgr

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:simple-git_project:simple-git:*:*:*:*:*:node.js:*:*before 4.0.0Vulnerablesteveukx
  • cpe:2.3:a:simple-git_project:simple-git:*:*:*:*:*:node.js:*:* Versions before 4.0.0 Vulnerable ·steveukx

Remediation

  • Fix · CNA git-js (steveukx) Fixed in 4.0.0
  • Fix · GHSA-g4wm-2vf7-vfgr simple-git (npm) Fixed in 4.0.0 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Build of KeycloakAffectedNo fix yet
Not affected: 5 products
  • Red Hat Enterprise Linux 10
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9
  • Red Hat JBoss Enterprise Application Platform 8
  • Red Hat JBoss Enterprise Application Platform Expansion Pack

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-102826
  2. 2026-10-06 Alias added: GHSA-g4wm-2vf7-vfgr
  3. 2026-10-06 Fix available: npm/[email protected] · GHSA-g4wm-2vf7-vfgr
  4. 2026-10-06 CVSS score added · GHSA-g4wm-2vf7-vfgr
  5. 2026-10-06 Weakness changed · GHSA-g4wm-2vf7-vfgr
  6. 2026-10-06 6 new references · GHSA-g4wm-2vf7-vfgr
  7. 2026-10-26 Affected versions changed · Red Hat

References

  • TI-2026-22598 simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key that enables RCE CVSS 3.1CRITICAL 9.8
  • TI-2022-09464 Remote code execution (RCE) in simple-git CVSS 3.1CRITICAL 9.8
  • TI-2026-06084 Code injection in simple-git CVSS 4.0CRITICAL 9.2
  • TI-2022-09425 Code injection in simple-git CVSS 3.1CRITICAL 9.8
  • TI-2026-22597 simple-git has Command Execution via Option-Parsing Bypass CVSS 3.1HIGH 8.1
  • TI-2022-08024 Command injection in simple-git CVSS 3.1CRITICAL 9.8
See all 9 →

Sources