Read the docs
TI-2026-22597 Aliases CVE-2026-28291GHSA-jcxm-m3jx-f287

simple-git has Command Execution via Option-Parsing Bypass

Priority HIGH 70CWE-78Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 2 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-78.

Summary

simple-git enables running native Git commands from JavaScript. Versions up to and including 3.31.1 allow execution of arbitrary commands through Git option manipulation, bypassing safety checks meant to block dangerous options like -u and --upload-pack. The flaw stems from an incomplete fix for CVE-2022-25860, as Git's flexible option parsing allows numerous character combinations (e.g., -vu, -4u, -nu) to circumvent the regular-expression-based blocklist in the unsafe operations plugin. Due to the virtually infinite number of valid option variants that Git accepts, a complete blocklist-based mitigation may be infeasible without fully emulating Git's option parsing behavior. This issue has been fixed in version 3.32.0.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00768 55th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial git-js (steveukx): 3.32.0simple-git (npm): 3.32.0Red Hat: 2 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
steveukxgit-jsbefore 3.32.03.32.0Patch availableCNA
—simple-git (npm)before 3.32.03.32.0Patch availableGHSA-jcxm-m3jx-f287
  • git-js Vendorsteveukx Affected before 3.32.0 Fixed in 3.32.0 Patch available CNA
  • simple-git (npm) Vendor— Affected before 3.32.0 Fixed in 3.32.0 Patch available GHSA-jcxm-m3jx-f287

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:simple-git_project:simple-git:*:*:*:*:*:node.js:*:*before 3.32.0Vulnerablesteveukx
  • cpe:2.3:a:simple-git_project:simple-git:*:*:*:*:*:node.js:*:* Versions before 3.32.0 Vulnerable ·steveukx

Remediation

  • Fix · CNA git-js (steveukx) Fixed in 3.32.0
  • Fix · GHSA-jcxm-m3jx-f287 simple-git (npm) Fixed in 3.32.0 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Build of KeycloakAffectedNo fix planned: Will not fix
Red Hat Process Automation 7AffectedNo fix yet
Not affected: 4 products
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9
  • Red Hat JBoss Enterprise Application Platform 8
  • Red Hat JBoss Enterprise Application Platform Expansion Pack

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-28291
  2. 2026-10-03 Alias added: GHSA-jcxm-m3jx-f287

References

  • TI-2026-22598 simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key that enables RCE CVSS 3.1CRITICAL 9.8
  • TI-2022-09464 Remote code execution (RCE) in simple-git CVSS 3.1CRITICAL 9.8
  • TI-2026-06084 Code injection in simple-git CVSS 4.0CRITICAL 9.2
  • TI-2022-09425 Code injection in simple-git CVSS 3.1CRITICAL 9.8
  • TI-2026-65515 simple-git allows command execution through unblocked Git configuration includes CVSS 3.1HIGH 8.1
  • TI-2022-08024 Command injection in simple-git CVSS 3.1CRITICAL 9.8
See all 9 →

Sources