Read the docs
TI-2026-06084 Aliases CVE-2026-6951GHSA-hffm-xvc3-vprc

Code injection in simple-git

Priority HIGH 81CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-94.

Summary

Versions of the package simple-git before 3.36.0 are vulnerable to Remote Code Execution (RCE) due to an incomplete fix for [CVE-2022-25912](https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-3112221) that blocks the -c option but not the equivalent --config form. If untrusted input can reach the options argument passed to simple-git, an attacker may still achieve remote code execution by enabling protocol.ext.allow=always and using an ext:: clone source.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00877 59th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial simple-git: 3.36.0simple-git (npm): 3.36.0Red Hat: 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—simple-gitbefore 3.36.03.36.0Patch availableCNA
—org.webjars.npm:simple-gitall versions—No fix listedCNA
—simple-git (npm)before 3.36.03.36.0Patch availableGHSA-hffm-xvc3-vprc
  • simple-git Vendor— Affected before 3.36.0 Fixed in 3.36.0 Patch available CNA
  • org.webjars.npm:simple-git Vendor— Affected all versions Fixed in — No fix listed CNA
  • simple-git (npm) Vendor— Affected before 3.36.0 Fixed in 3.36.0 Patch available GHSA-hffm-xvc3-vprc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:simple-git_project:simple-git:*:*:*:*:*:node.js:*:*3.15.0 to before 3.36.0Vulnerablesteveukx
  • cpe:2.3:a:simple-git_project:simple-git:*:*:*:*:*:node.js:*:* Versions 3.15.0 to before 3.36.0 Vulnerable ·steveukx

Remediation

  • Fix · CNA simple-git Fixed in 3.36.0
  • Fix · GHSA-hffm-xvc3-vprc simple-git (npm) Fixed in 3.36.0 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 8AffectedNo fix planned: Will not fix
Not affected: 4 products
  • Red Hat Enterprise Linux 9
  • Red Hat JBoss Enterprise Application Platform 8
  • Red Hat JBoss Enterprise Application Platform Expansion Pack
  • Red Hat Process Automation 7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-6951
  2. 2026-10-03 Alias added: GHSA-hffm-xvc3-vprc

References

  • TI-2026-22598 simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key that enables RCE CVSS 3.1CRITICAL 9.8
  • TI-2022-09464 Remote code execution (RCE) in simple-git CVSS 3.1CRITICAL 9.8
  • TI-2022-09425 Code injection in simple-git CVSS 3.1CRITICAL 9.8
  • TI-2026-65515 simple-git allows command execution through unblocked Git configuration includes CVSS 3.1HIGH 8.1
  • TI-2026-22597 simple-git has Command Execution via Option-Parsing Bypass CVSS 3.1HIGH 8.1
  • TI-2022-08024 Command injection in simple-git CVSS 3.1CRITICAL 9.8
See all 9 →

Sources