Database bypassing any permissions in Metabase via SQlite attach
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Metabase is an open source business intelligence and analytics application. SQLite has an FDW-like feature called `ATTACH DATABASE`, which allows connecting multiple SQLite databases via the initial connection. If the attacker has SQL permissions to at least one SQLite database, then it can attach this database to a second database, and then it can query across all the tables. To be able to do that the attacker also needs to know the file path to the second database. Users are advised to upgrade as soon as possible. If you're unable to upgrade, you can modify your SQLIte connection strings to contain the url argument `?limit_attached=0`, which will disallow making connections to other SQLite databases. Only users making use of SQLite are affected.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Metabase | metabase | 1.41.0 to before 1.41.7; 0.41.0 to before 0.41.7; 1.42.0 to before 1.42.4; 0.42.0 to before 0.42.4 | 1.41.7, 0.41.7, 1.42.4, 0.42.4 | Patch available | CNA |
- metabase VendorMetabase Affected 1.41.0 to before 1.41.7; 0.41.0 to before 0.41.7; 1.42.0 to before 1.42.4; 0.42.0 to before 0.42.4 Fixed in 1.41.7, 0.41.7, 1.42.4, 0.42.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:metabase:metabase:*:*:*:*:*:*:*:* | 0.41.0 to before 0.41.7; 0.42.0 to before 0.42.4; 1.41.0 to before 1.41.7; 1.42.0 to before 1.42.4 | Vulnerable | Metabase |
- cpe:2.3:a:metabase:metabase:*:*:*:*:*:*:*:* Versions 0.41.0 to before 0.41.7; 0.42.0 to before 0.42.4; 1.41.0 to before 1.41.7; 1.42.0 to before 1.42.4 Vulnerable ·Metabase
Remediation
- Fix · CNA metabase (metabase) Fixed in 1.41.7, 0.41.7, 1.42.4, 0.42.4
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24854
References
More Metabase vulnerabilities
- TI-2026-51115 Metabase SQL injection via password reset endpoint KEVCVSS 4.0CRITICAL 10.0
- TI-2021-18109 GeoJSON URL validation can expose server files and environment variables to unauthorized users KEVCVSS 3.1CRITICAL 10.0
- TI-2023-20003 Metabase open source before 0.46.6.1 and Metabase Enterprise before 1.46.6.1 allow… CVSS 3.1CRITICAL 9.8
- TI-2022-08664 File system exposure in Metabase CVSS 3.1MEDIUM 5.9
- TI-2025-05321 Metabase dom.js parseDataUri redos CVSS 4.0MEDIUM 5.3
- TI-2023-19078 Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint CVSS 3.1CRITICAL 10.0
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences