Read the docs
TI-2022-08666 Aliases CVE-2022-24855

XSS vulnerability in Metabase

Priority MEDIUM 41CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Metabase is an open source business intelligence and analytics application. In affected versions Metabase ships with an internal development endpoint `/_internal` that can allow for cross site scripting (XSS) attacks, potentially leading to phishing attempts with malicious links that could lead to account takeover. Users are advised to either upgrade immediately, or block access in your firewall to `/_internal` endpoints for Metabase. The following patches (or greater versions) are available: 0.42.4 and 1.42.4, 0.41.7 and 1.41.7, 0.40.8 and 1.40.8.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00712 53rd percentileScored 2026-11-07
Fix Fixed metabase (metabase): 1.40.8, 0.40.8, 1.41.7 +3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Metabasemetabase1.40.0 to before 1.40.8; 0.40.0 to before 0.40.8; 1.41.0 to before 1.41.7; 0.41.0 to before 0.41.7; 1.42.0 to before 1.42.4; 0.42.0 to before 0.42.41.40.8, 0.40.8, 1.41.7, 0.41.7, 1.42.4, 0.42.4Patch availableCNA
  • metabase VendorMetabase Affected 1.40.0 to before 1.40.8; 0.40.0 to before 0.40.8; 1.41.0 to before 1.41.7; 0.41.0 to before 0.41.7; 1.42.0 to before 1.42.4; 0.42.0 to before 0.42.4 Fixed in 1.40.8, 0.40.8, 1.41.7, 0.41.7, 1.42.4, 0.42.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:metabase:metabase:*:*:*:*:*:*:*:*0.40.0 to before 0.40.8; 0.41.0 to before 0.41.7; 0.42.0 to before 0.42.4; 1.40.0 to before 1.40.8; 1.41.0 to before 1.41.7; 1.42.0 to before 1.42.4VulnerableMetabase
  • cpe:2.3:a:metabase:metabase:*:*:*:*:*:*:*:* Versions 0.40.0 to before 0.40.8; 0.41.0 to before 0.41.7; 0.42.0 to before 0.42.4; 1.40.0 to before 1.40.8; 1.41.0 to before 1.41.7; 1.42.0 to before 1.42.4 Vulnerable ·Metabase

Remediation

  • Fix · CNA metabase (metabase) Fixed in 1.40.8, 0.40.8, 1.41.7, 0.41.7, 1.42.4, 0.42.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-24855

References

  • TI-2026-51115 Metabase SQL injection via password reset endpoint KEVCVSS 4.0CRITICAL 10.0
  • TI-2021-18109 GeoJSON URL validation can expose server files and environment variables to unauthorized users KEVCVSS 3.1CRITICAL 10.0
  • TI-2023-20003 Metabase open source before 0.46.6.1 and Metabase Enterprise before 1.46.6.1 allow… CVSS 3.1CRITICAL 9.8
  • TI-2022-08664 File system exposure in Metabase CVSS 3.1MEDIUM 5.9
  • TI-2025-05321 Metabase dom.js parseDataUri redos CVSS 4.0MEDIUM 5.3
  • TI-2023-19078 Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint CVSS 3.1CRITICAL 10.0
See all 25 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences