OS command injection in Jenkins Pipeline: Shared Groovy Libraries Plugin
Priority MEDIUM 41CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-78.
Summary
Jenkins Pipeline: Shared Groovy Libraries Plugin 552.vd9cc05b8a2e1 and earlier uses the same checkout directories for distinct SCMs for Pipeline libraries, allowing attackers with Item/Configure permission to invoke arbitrary OS commands on the controller through crafted SCM contents.
Why it matters now
EPSS 0.01404 72nd percentileScored 2026-11-07
Fix Fixed Jenkins Pipeline: Shared Groovy Libraries Plugin (Jenkins project): 2.21.1, 2.18.1org.jenkins-ci.plugins.workflow:workflow-cps-global-lib (Maven): 561.va, 2.21.1, 2.18.1Red Hat: 6 advisories
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Pipeline: Shared Groovy Libraries Plugin | up to 552.vd9cc05b8a2e1 | 2.21.1, 2.18.1 | Patch available | CNA |
| — | org.jenkins-ci.plugins.workflow:workflow-cps-global-lib (Maven) | 544.vff04fa68714d to before 561.va | 561.va | Patch available | GHSA-g9fx-6j5c-grmw |
| — | org.jenkins-ci.plugins.workflow:workflow-cps-global-lib (Maven) | 2.19 to before 2.21.1 | 2.21.1 | Patch available | GHSA-g9fx-6j5c-grmw |
| — | org.jenkins-ci.plugins.workflow:workflow-cps-global-lib (Maven) | before 2.18.1 | 2.18.1 | Patch available | GHSA-g9fx-6j5c-grmw |
- Jenkins Pipeline: Shared Groovy Libraries Plugin VendorJenkins Affected up to 552.vd9cc05b8a2e1 Fixed in 2.21.1, 2.18.1 Patch available CNA
- org.jenkins-ci.plugins.workflow:workflow-cps-global-lib (Maven) Vendor— Affected 544.vff04fa68714d to before 561.va Fixed in 561.va Patch available GHSA-g9fx-6j5c-grmw
- org.jenkins-ci.plugins.workflow:workflow-cps-global-lib (Maven) Vendor— Affected 2.19 to before 2.21.1 Fixed in 2.21.1 Patch available GHSA-g9fx-6j5c-grmw
- org.jenkins-ci.plugins.workflow:workflow-cps-global-lib (Maven) Vendor— Affected before 2.18.1 Fixed in 2.18.1 Patch available GHSA-g9fx-6j5c-grmw
Remediation
- Fix · CNA Jenkins Pipeline: Shared Groovy Libraries Plugin (Jenkins project) Fixed in 2.21.1, 2.18.1
- Fix · GHSA-g9fx-6j5c-grmw org.jenkins-ci.plugins.workflow:workflow-cps-global-lib (Maven) Fixed in 561.va Advisory →
- Fix · GHSA-g9fx-6j5c-grmw org.jenkins-ci.plugins.workflow:workflow-cps-global-lib (Maven) Fixed in 2.21.1 Advisory →
- Fix · GHSA-g9fx-6j5c-grmw org.jenkins-ci.plugins.workflow:workflow-cps-global-lib (Maven) Fixed in 2.18.1 Advisory →
Red Hat 6 advisories
- RHSA-2022:1620 Released 2022-05-04 · Red Hat rating ImportantOpenShift Container Platform 4.6.57 packages and security update
- Red Hat OpenShift Container Platform 4.6 haproxy-2.0.16-3.el7, haproxy-2.0.16-5.el8, haproxy20-2.0.16-3.el7 +2
- RHSA-2022:1420 Released 2022-04-27 · Red Hat rating ImportantOpenShift Container Platform 3.11.685 security and bug fix update
- Red Hat OpenShift Container Platform 3.11 jenkins-2-plugins-3.11.1650371376-1.el7, jenkins-2.319.3.1650348949-1.el7
- RHSA-2022:1248 Released 2022-04-13 · Red Hat rating ImportantOpenShift Container Platform 4.7.48 packages and security update
- Red Hat OpenShift Container Platform 4.7 jenkins-2-plugins-4.7.1648800585-1.el8
Show 3 more Red Hat advisories
- RHSA-2022:1021 Released 2022-03-29 · Red Hat rating ImportantOpenShift Container Platform 4.9.26 security update
- Red Hat OpenShift Container Platform 4.9 haproxy-2.2.15-4.el8, haproxy22-2.2.15-4.el8, jenkins-2-plugins-4.9.1647580879-1.el8
- RHSA-2022:1025 Released 2022-03-28 · Red Hat rating ImportantOpenShift Container Platform 4.10.6 security update
- Red Hat OpenShift Container Platform 4.10 jenkins-2-plugins-4.10.1647505461-1.el8
- RHSA-2022:0871 Released 2022-03-22 · Red Hat rating ImportantOpenShift Container Platform 4.8.35 security update
- Red Hat OpenShift Container Platform 4.8 cri-o-1.21.5-3.rhaos4.8.gitaf64931.el7, cri-o-1.21.5-3.rhaos4.8.gitaf64931.el8, jenkins-2-plugins-4.8.1646993358-1.el8
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Fixed | RHSA-2022:1420 |
| Red Hat OpenShift Container Platform 4.10 | Fixed | RHSA-2022:1025 |
| Red Hat OpenShift Container Platform 4.6 | Fixed | RHSA-2022:1620 |
| Red Hat OpenShift Container Platform 4.7 | Fixed | RHSA-2022:1248 |
| Red Hat OpenShift Container Platform 4.8 | Fixed | RHSA-2022:0871 |
| Red Hat OpenShift Container Platform 4.9 | Fixed | RHSA-2022:1021 |
Not affected: 5 products
- Red Hat OpenShift Container Platform 3.11
- Red Hat OpenShift Container Platform 4.10
- Red Hat OpenShift Container Platform 4.6
- Red Hat OpenShift Container Platform 4.8
- Red Hat OpenShift Container Platform 4.9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25174
- 2026-10-03 Alias added: GHSA-g9fx-6j5c-grmw
References
More Jenkins Pipeline vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15846 A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.61 and earlier in… CVSS 3.1HIGH 8.8
- TI-2019-15847 A sandbox bypass vulnerability exists in Pipeline: Declarative Plugin 1.3.3 and earlier… CVSS 3.1HIGH 8.8
- TI-2023-11034 Cross-site scripting in Jenkins Pipeline: Build Step Plugin CVSS 3.1MEDIUM 5.4
- TI-2019-15886 A sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin 2.64 and earlier allows… CVSS 3.1CRITICAL 9.8
- TI-2022-21197 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-25174 · CVE Program
- CVE-2022-25174 · NVD
- FIRST EPSS
- GHSA-g9fx-6j5c-grmw · GitHub Advisory Database · CC BY 4.0
- CVE-2022-25174 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences