Read the docs
TI-2022-13002 Aliases CVE-2022-30946GHSA-qwgx-mrv5-87j8

Cross-site request forgery in Jenkins Script Security Plugin

Priority LOW 21CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · Low · None
Fix status
Partial Red Hat: 3 fixed, 1 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-352.

Summary

A cross-site request forgery (CSRF) vulnerability in Jenkins Script Security Plugin 1158.v7c1b_73a_69a_08 and earlier allows attackers to have Jenkins send an HTTP request to an attacker-specified webserver.

Why it matters now

EPSS 0.00654 51st percentileScored 2026-11-07
Fix Partial Jenkins Script Security Plugin (Jenkins project): 1.78.1, 1145.1148.vf6d17a_a_a_eef6org.jenkins-ci.plugins:script-security (Maven): 1172.v35f6aRed Hat: 3 advisoriesRed Hat: 3 fixed, 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Script Security Pluginup to 1158.v7c1b_73a_69a_081.78.1, 1145.1148.vf6d17a_a_a_eef6Patch availableCNA
—org.jenkins-ci.plugins:script-security (Maven)before 1172.v35f6a1172.v35f6aPatch availableGHSA-qwgx-mrv5-87j8
  • Jenkins Script Security Plugin VendorJenkins Affected up to 1158.v7c1b_73a_69a_08 Fixed in 1.78.1, 1145.1148.vf6d17a_a_a_eef6 Patch available CNA
  • org.jenkins-ci.plugins:script-security (Maven) Vendor— Affected before 1172.v35f6a Fixed in 1172.v35f6a Patch available GHSA-qwgx-mrv5-87j8

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:script_security:*:*:*:*:*:jenkins:*:*before 1172.v35f6a_0b_8207eVulnerableJenkins
  • cpe:2.3:a:jenkins:script_security:*:*:*:*:*:jenkins:*:* Versions before 1172.v35f6a_0b_8207e Vulnerable ·Jenkins

Remediation

  • Fix · CNA Jenkins Script Security Plugin (Jenkins project) Fixed in 1.78.1, 1145.1148.vf6d17a_a_a_eef6
  • Fix · GHSA-qwgx-mrv5-87j8 org.jenkins-ci.plugins:script-security (Maven) Fixed in 1172.v35f6a Advisory →

Red Hat 3 advisories

  • RHSA-2023:0777 Released 2023-02-23 · Red Hat rating Critical
    OpenShift Container Platform 4.9.56 security update
    • Red Hat OpenShift Container Platform 4.9 jenkins-2-plugins-4.9.1675668922-1.el8, jenkins-2.361.1.1675668150-1.el8
  • RHSA-2023:0560 Released 2023-02-08 · Red Hat rating Critical
    OpenShift Container Platform 4.10.51 security update
    • Red Hat OpenShift Container Platform 4.10 jenkins-2-plugins-4.10.1675144701-1.el8
  • RHSA-2023:0017 Released 2023-01-12 · Red Hat rating Important
    OpenShift Container Platform 4.8.56 packages and security update
    • Red Hat OpenShift Container Platform 4.8 jenkins-2-plugins-4.8.1672842762-1.el8, jenkins-2.361.1.1672840472-1.el8

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.11AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 4.10Fixed RHSA-2023:0560
Red Hat OpenShift Container Platform 4.8Fixed RHSA-2023:0017
Red Hat OpenShift Container Platform 4.9Fixed RHSA-2023:0777
Not affected: 3 products
  • Red Hat OpenShift Container Platform 4.10
  • Red Hat OpenShift Container Platform 4.8
  • Red Hat OpenShift Container Platform 4.9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-30946
  2. 2026-10-03 Alias added: GHSA-qwgx-mrv5-87j8
  3. 2026-10-14 EPSS moved to the 50th–90th percentile

References

  • TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
  • TI-2019-15845 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
  • TI-2024-22597 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.8
  • TI-2019-15850 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
  • TI-2019-15885 A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.55 and earlier allows… CVSS 3.1CRITICAL 9.8
  • TI-2019-07740 Code injection in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.9
See all 44 →

Sources