Apache Commons Configuration insecure interpolation defaults
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 3 fixed, 7 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Apache Commons Configuration performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.configuration2.interpol.Lookup that performs the interpolation. Starting with version 2.4 and continuing through 2.7, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - "script" - execute expressions using the JVM script execution engine (javax.script) - "dns" - resolve dns records - "url" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Configuration 2.8.0, which disables the problematic interpolators by default.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Commons Configuration | Apache Commons Configuration to before 2.8.0 | 2.8.0 | Patch available | CNA |
| — | org.apache.commons:commons-configuration2 (Maven) | 2.4 to before 2.8.0 | 2.8.0 | Patch available | GHSA-xj57-8qj4-c4m6 |
- Apache Commons Configuration VendorApache Affected Apache Commons Configuration to before 2.8.0 Fixed in 2.8.0 Patch available CNA
- org.apache.commons:commons-configuration2 (Maven) Vendor— Affected 2.4 to before 2.8.0 Fixed in 2.8.0 Patch available GHSA-xj57-8qj4-c4m6
Remediation
- Fix · CNA Apache Commons Configuration (Apache Software Foundation) Fixed in 2.8.0
- Fix · GHSA-xj57-8qj4-c4m6 org.apache.commons:commons-configuration2 (Maven) Fixed in 2.8.0 Advisory →
Red Hat 3 advisories
- RHSA-2023:2097 Released 2023-05-03 · Red Hat rating ImportantSatellite 6.13 Release
- Red Hat Satellite 6.13 for RHEL 8 ansible-collection-redhat-satellite-3.9.0-2.el8sat, ansible-collection-redhat-satellite_operations-1.3.0-2.el8sat, ansible-lint-5.0.8-4.el8pc +47
- RHSA-2022:8652 Released 2022-11-28 · Red Hat rating ImportantRed Hat Fuse 7.11.1 release and security update
- Red Hat Fuse 7.11.1
- RHSA-2022:6916 Released 2022-10-12 · Red Hat rating ImportantRed Hat AMQ Broker 7.10.1 release and security update
- AMQ Broker 7.10.1
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Decision Manager 7 | Affected | No fix planned: Out of support scope |
| Red Hat Integration Camel K 1 | Affected | No fix yet |
| Red Hat JBoss Data Grid 7 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet |
| Red Hat Process Automation 7 | Affected | No fix planned: Out of support scope |
| Red Hat support for Spring Boot | Affected | No fix yet |
| AMQ Broker 7.10.1 | Fixed | RHSA-2022:6916 |
| Red Hat Fuse 7.11.1 | Fixed | RHSA-2022:8652 |
| Red Hat Satellite 6.13 for RHEL 8 | Fixed | RHSA-2023:2097 |
Not affected: 7 products
- A-MQ Clients 2
- Red Hat A-MQ Online
- Red Hat Data Grid 8
- Red Hat JBoss Enterprise Application Platform 7
- Red Hat JBoss Enterprise Application Platform Expansion Pack
- Red Hat Satellite 6.13 for RHEL 8
- Red Hat build of Quarkus
Timeline
- 2026-10-02 Threatist record created from CVE-2022-33980
- 2026-10-03 Alias added: GHSA-xj57-8qj4-c4m6
References
Advisory 6
- https://lists.apache.org/thread/tdf5n7j80lfxdhs2764vn0xmpfodm87s
- [oss-security] 20220706 CVE-2022-33980: Apache Commons Configuration insecure interpolation defaults
- https://security.netapp.com/advisory/ntap-20221028-0015/
- [oss-security] 20221115 Multiple vulnerabilities in Jenkins plugins
- DSA-5290
- https://nvd.nist.gov/vuln/detail/CVE-2022-33980
Other 5
More Apache Commons Configuration vulnerabilities
- TI-2020-01877 Improper input validation in Apache Commons Configuration CVSS 3.1CRITICAL 10.0
- TI-2024-19305 Apache Commons Configuration: StackOverflowError adding property in AbstractListDelimiterHandler.flattenIterator() CVSS 3.1HIGH 7.3
- TI-2025-29118 Apache Commons Configuration: Uncontrolled Resource Consumption when loading untrusted configurations in 1.x CVSS 3.1MEDIUM 6.5
- TI-2026-33022 Apache Commons Configuration: StackOverflowError for YAML input with cycles CVSS 3.1MEDIUM 5.3
- TI-2024-19306 Out-of-bounds write in Apache Commons Configuration CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-33980 · CVE Program
- CVE-2022-33980 · NVD
- FIRST EPSS
- GHSA-xj57-8qj4-c4m6 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-33980 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences