Apache Commons Configuration: StackOverflowError for YAML input with cycles
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Partial Red Hat: 3 fixed, 5 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-674.
Summary
Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Commons Configuration | 2.2 to before 2.15.0 | 2.15.0 | Patch available | CNA |
| — | org.apache.commons:commons-configuration2 (Maven) | 2.2 to before 2.15.0 | 2.15.0 | Patch available | GHSA-337m-mw94-2v6g |
- Apache Commons Configuration VendorApache Affected 2.2 to before 2.15.0 Fixed in 2.15.0 Patch available CNA
- org.apache.commons:commons-configuration2 (Maven) Vendor— Affected 2.2 to before 2.15.0 Fixed in 2.15.0 Patch available GHSA-337m-mw94-2v6g
Remediation
- Fix · CNA Apache Commons Configuration (Apache Software Foundation) Fixed in 2.15.0
- Fix · GHSA-337m-mw94-2v6g org.apache.commons:commons-configuration2 (Maven) Fixed in 2.15.0 Advisory →
Red Hat 3 advisories
- RHSA-2026:66545 Released 2026-09-10 · Red Hat rating ImportantRed Hat AMQ Broker 7.13.6 release and security update
- Red Hat AMQ Broker 7.13.6
- RHSA-2026:66488 Released 2026-09-10 · Red Hat rating ImportantRed Hat AMQ Broker 7.14.1 release and security update
- Red Hat AMQ Broker 7.14.1
- RHSA-2026:54622 Released 2026-08-13 · Red Hat rating ImportantRed Hat Build of Apache Camel 4.18.3 for Spring Boot release.
- Red Hat build of Apache Camel 4.18.3 for Spring Boot 3.5.16
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Developer Tools and Services | Affected | No fix yet |
| Red Hat AMQ Clients | Affected | No fix yet |
| Red Hat Enterprise Linux 6 | Affected | No fix yet |
| Red Hat Single Sign-On 7 | Affected | No fix planned: Will not fix |
| Red Hat build of Apicurio Registry 3 | Affected | No fix yet |
| Red Hat AMQ Broker 7.13.6 | Fixed | RHSA-2026:66545 |
| Red Hat AMQ Broker 7.14.1 | Fixed | RHSA-2026:66488 |
| Red Hat build of Apache Camel 4.18.3 for Spring Boot 3.5.16 | Fixed | RHSA-2026:54622 |
Not affected: 7 products
- Red Hat Data Grid 8
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat JBoss Enterprise Application Platform 7
- Red Hat JBoss Enterprise Application Platform Expansion Pack
- Red Hat OpenShift AI (RHOAI)
- Red Hat Satellite 6
Timeline
- 2026-10-02 Threatist record created from CVE-2026-45205
- 2026-10-03 Alias added: GHSA-337m-mw94-2v6g
- 2026-10-16 Affected versions changed · Red Hat
- 2026-10-25 EPSS moved to the below the 50th percentile
References
More Apache Commons Configuration vulnerabilities
- TI-2022-14972 Apache Commons Configuration insecure interpolation defaults CVSS 3.1CRITICAL 9.8
- TI-2020-01877 Improper input validation in Apache Commons Configuration CVSS 3.1CRITICAL 10.0
- TI-2024-19305 Apache Commons Configuration: StackOverflowError adding property in AbstractListDelimiterHandler.flattenIterator() CVSS 3.1HIGH 7.3
- TI-2025-29118 Apache Commons Configuration: Uncontrolled Resource Consumption when loading untrusted configurations in 1.x CVSS 3.1MEDIUM 6.5
- TI-2024-19306 Out-of-bounds write in Apache Commons Configuration CVSS 3.1MEDIUM 5.4
Sources
- CVE-2026-45205 · CVE Program
- CVE-2026-45205 · NVD
- FIRST EPSS
- GHSA-337m-mw94-2v6g · GitHub Advisory Database · CC BY 4.0
- CVE-2026-45205 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences