Apache Commons Configuration: Uncontrolled Resource Consumption when loading untrusted configurations in 1.x
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-400.
Summary
Uncontrolled Resource Consumption vulnerability in Apache Commons Configuration 1.x. There are a number of issues in Apache Commons Configuration 1.x that allow excessive resource consumption when loading untrusted configurations or using unexpected usage patterns. The Apache Commons Configuration team does not intend to fix these issues in 1.x. Apache Commons Configuration 1.x is still safe to use in scenario's where you only load trusted configurations. Users that load untrusted configurations or give attackers control over usage patterns are recommended to upgrade to the 2.x version line, which fixes these issues. Apache Commons Configuration 2.x is not a drop-in replacement, but as it uses a separate Maven groupId and Java package namespace they can be loaded side-by-side, making it possible to do a gradual migration.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Commons Configuration | 1 to before 2.0.0 | 2.0.0 | Patch available | CNA |
| — | commons-configuration:commons-configuration (Maven) | up to 1.10 | — | No fix listed | GHSA-pvp8-3xj6-8c6x |
- Apache Commons Configuration VendorApache Affected 1 to before 2.0.0 Fixed in 2.0.0 Patch available CNA
- commons-configuration:commons-configuration (Maven) Vendor— Affected up to 1.10 Fixed in — No fix listed GHSA-pvp8-3xj6-8c6x
Remediation
- Fix · CNA Apache Commons Configuration (Apache Software Foundation) Fixed in 2.0.0
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-46392
- 2026-10-03 Alias added: GHSA-pvp8-3xj6-8c6x
References
More Apache Commons Configuration vulnerabilities
- TI-2022-14972 Apache Commons Configuration insecure interpolation defaults CVSS 3.1CRITICAL 9.8
- TI-2020-01877 Improper input validation in Apache Commons Configuration CVSS 3.1CRITICAL 10.0
- TI-2024-19305 Apache Commons Configuration: StackOverflowError adding property in AbstractListDelimiterHandler.flattenIterator() CVSS 3.1HIGH 7.3
- TI-2026-33022 Apache Commons Configuration: StackOverflowError for YAML input with cycles CVSS 3.1MEDIUM 5.3
- TI-2024-19306 Out-of-bounds write in Apache Commons Configuration CVSS 3.1MEDIUM 5.4
Sources
- CVE-2025-46392 · CVE Program
- CVE-2025-46392 · NVD
- FIRST EPSS
- GHSA-pvp8-3xj6-8c6x · GitHub Advisory Database · CC BY 4.0
- CVE-2025-46392 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences