Out-of-bounds write in Apache Commons Configuration
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 3 fixed, 8 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat.
Summary
Out-of-bounds Write vulnerability in Apache Commons Configuration.This issue affects Apache Commons Configuration: from 2.0 before 2.10.1. Users are recommended to upgrade to version 2.10.1, which fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Commons Configuration | 2.0 to before 2.10.1 | 2.10.1 | Patch available | CNA |
| — | org.apache.commons:commons-configuration2 (Maven) | 2.0 to before 2.10.1 | 2.10.1 | Patch available | GHSA-9w38-p64v-xpmv |
- Apache Commons Configuration VendorApache Affected 2.0 to before 2.10.1 Fixed in 2.10.1 Patch available CNA
- org.apache.commons:commons-configuration2 (Maven) Vendor— Affected 2.0 to before 2.10.1 Fixed in 2.10.1 Patch available GHSA-9w38-p64v-xpmv
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:commons_configuration:*:*:*:*:*:*:*:* | 2.0 to before 2.10.1 | Vulnerable | Apache |
| cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* | 39 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:40:*:*:*:*:*:*:* | 40 | Vulnerable | Fedoraproject |
- cpe:2.3:a:apache:commons_configuration:*:*:*:*:*:*:*:* Versions 2.0 to before 2.10.1 Vulnerable ·Apache
- cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* Versions 39 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:40:*:*:*:*:*:*:* Versions 40 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA Apache Commons Configuration (Apache Software Foundation) Fixed in 2.10.1
- Fix · GHSA-9w38-p64v-xpmv org.apache.commons:commons-configuration2 (Maven) Fixed in 2.10.1 Advisory →
Red Hat 3 advisories
- RHSA-2024:3989 Released 2024-06-20 · Red Hat rating ImportantMigration Toolkit for Applications security and bug fix update
- MTA 6.2 for RHEL 8 mta/mta-ui-rhel9, mta/mta-windup-addon-rhel9
- RHSA-2024:3920 Released 2024-06-13 · Red Hat rating ImportantMigration Toolkit for Runtimes security, bug fix and enhancement update
- Migration Toolkit for Runtimes 1 on RHEL 8
- RHSA-2024:2945 Released 2024-05-21 · Red Hat rating ImportantRed Hat AMQ Broker 7.12.0 release and security update
- Red Hat AMQ Broker 7
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache Commons Configuration 2.10.1
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2024-19305 Apache Commons Configuration: StackOverflowError adding property in AbstractListDelimiterHandler.flattenIterator()Priority MEDIUM 42
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| A-MQ Clients 2 | Affected | No fix yet: Fix deferred |
| OpenShift Developer Tools and Services | Affected | No fix yet: Fix deferred |
| Red Hat Fuse 7 | Affected | No fix planned: Out of support scope |
| Red Hat Integration Camel K 1 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Out of support scope |
| Red Hat Process Automation 7 | Affected | No fix planned: Out of support scope |
| Red Hat Single Sign-On 7 | Affected | No fix planned: Out of support scope |
| Red Hat support for Spring Boot | Affected | No fix planned: Out of support scope |
| MTA 6.2 for RHEL 8 | Fixed | RHSA-2024:3989 |
| Migration Toolkit for Runtimes 1 on RHEL 8 | Fixed | RHSA-2024:3920 |
| Red Hat AMQ Broker 7 | Fixed | RHSA-2024:2945 |
Not affected: 11 products
- MTA 6.2 for RHEL 8
- Red Hat AMQ Clients
- Red Hat Data Grid 8
- Red Hat JBoss Data Grid 7
- Red Hat JBoss Enterprise Application Platform 7
- Red Hat JBoss Enterprise Application Platform 8
- Red Hat JBoss Enterprise Application Platform Expansion Pack
- Red Hat build of Apache Camel 4 for Quarkus 3
- Red Hat build of Apache Camel for Spring Boot 3
- Red Hat build of Apache Camel for Spring Boot 4
- Red Hat build of OptaPlanner 8
Timeline
- 2026-10-02 Threatist record created from CVE-2024-29133
- 2026-10-03 Alias added: GHSA-9w38-p64v-xpmv
References
Advisory 5
- https://lists.apache.org/thread/ccb9w15bscznh6tnp3wsvrrj9crbszh2
- https://lists.fedoraproject.org/archives/list/[email protected]/message/YD4AFTIIQW662LUAQRMWS6BBKYSZG3YS/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/SNKDKEEKZNL5FGCTZKJ6CFXFVWFL5FJ7/
- http://www.openwall.com/lists/oss-security/2024/03/20/3
- https://nvd.nist.gov/vuln/detail/CVE-2024-29133
Other 4
- https://github.com/apache/commons-configuration/commit/43f4dab021e9acb8db390db2ae80aa0cee4f9ee4
- https://issues.apache.org/jira/browse/CONFIGURATION-841
- https://lists.fedoraproject.org/archives/list/[email protected]/message/SNKDKEEKZNL5FGCTZKJ6CFXFVWFL5FJ7
- https://lists.fedoraproject.org/archives/list/[email protected]/message/YD4AFTIIQW662LUAQRMWS6BBKYSZG3YS
More Apache Commons Configuration vulnerabilities
- TI-2022-14972 Apache Commons Configuration insecure interpolation defaults CVSS 3.1CRITICAL 9.8
- TI-2020-01877 Improper input validation in Apache Commons Configuration CVSS 3.1CRITICAL 10.0
- TI-2024-19305 Apache Commons Configuration: StackOverflowError adding property in AbstractListDelimiterHandler.flattenIterator() CVSS 3.1HIGH 7.3
- TI-2025-29118 Apache Commons Configuration: Uncontrolled Resource Consumption when loading untrusted configurations in 1.x CVSS 3.1MEDIUM 6.5
- TI-2026-33022 Apache Commons Configuration: StackOverflowError for YAML input with cycles CVSS 3.1MEDIUM 5.3
Sources
- CVE-2024-29133 · CVE Program
- CVE-2024-29133 · NVD
- FIRST EPSS
- GHSA-9w38-p64v-xpmv · GitHub Advisory Database · CC BY 4.0
- CVE-2024-29133 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences