Path traversal in Jenkins Pipeline: Input Step Plugin
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Partial Red Hat: 3 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Jenkins Pipeline: Input Step Plugin 448.v37cea_9a_10a_70 and earlier archives files uploaded for `file` parameters for Pipeline `input` steps on the controller as part of build metadata, using the parameter name without sanitization as a relative path inside a build-related directory, allowing attackers able to configure Pipelines to create or replace arbitrary files on the Jenkins controller file system with attacker-specified content.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Pipeline: Input Step Plugin | up to 448.v37cea_9a_10a_70 | 447.449.v193fd29f6021, 2.12.2 | Patch available | CNA |
| — | org.jenkins-ci.plugins:pipeline-input-step (Maven) | before 449.v77f0e8b | 449.v77f0e8b | Patch available | GHSA-29q6-p2cg-4v23 |
- Jenkins Pipeline: Input Step Plugin VendorJenkins Affected up to 448.v37cea_9a_10a_70 Fixed in 447.449.v193fd29f6021, 2.12.2 Patch available CNA
- org.jenkins-ci.plugins:pipeline-input-step (Maven) Vendor— Affected before 449.v77f0e8b Fixed in 449.v77f0e8b Patch available GHSA-29q6-p2cg-4v23
Remediation
- Fix · CNA Jenkins Pipeline: Input Step Plugin (Jenkins project) Fixed in 447.449.v193fd29f6021, 2.12.2
- Fix · GHSA-29q6-p2cg-4v23 org.jenkins-ci.plugins:pipeline-input-step (Maven) Fixed in 449.v77f0e8b Advisory →
Red Hat 3 advisories
- RHSA-2023:0017 Released 2023-01-12 · Red Hat rating ImportantOpenShift Container Platform 4.8.56 packages and security update
- Red Hat OpenShift Container Platform 4.8 jenkins-2-plugins-4.8.1672842762-1.el8, jenkins-2.361.1.1672840472-1.el8
- RHSA-2022:9110 Released 2023-01-06 · Red Hat rating ImportantOpenShift Container Platform 4.9.54 packages and security update
- Red Hat OpenShift Container Platform 4.9 jenkins-2-plugins-4.9.1669894222-1.el8
- RHSA-2022:6531 Released 2022-09-21 · Red Hat rating ImportantOpenShift Container Platform 4.10.33 packages and security update
- Red Hat OpenShift Container Platform 4.10 jenkins-2-plugins-4.10.1663147786-1.el8
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 4.10 | Fixed | RHSA-2022:6531 |
| Red Hat OpenShift Container Platform 4.8 | Fixed | RHSA-2023:0017 |
| Red Hat OpenShift Container Platform 4.9 | Fixed | RHSA-2022:9110 |
Not affected: 3 products
- Red Hat OpenShift Container Platform 4.10
- Red Hat OpenShift Container Platform 4.8
- Red Hat OpenShift Container Platform 4.9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-34177
- 2026-10-03 Alias added: GHSA-29q6-p2cg-4v23
References
More Jenkins Pipeline vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15846 A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.61 and earlier in… CVSS 3.1HIGH 8.8
- TI-2019-15847 A sandbox bypass vulnerability exists in Pipeline: Declarative Plugin 1.3.3 and earlier… CVSS 3.1HIGH 8.8
- TI-2023-11034 Cross-site scripting in Jenkins Pipeline: Build Step Plugin CVSS 3.1MEDIUM 5.4
- TI-2019-15886 A sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin 2.64 and earlier allows… CVSS 3.1CRITICAL 9.8
- TI-2022-21197 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-34177 · CVE Program
- CVE-2022-34177 · NVD
- FIRST EPSS
- GHSA-29q6-p2cg-4v23 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-34177 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences