Read the docs
TI-2022-16115 Aliases CVE-2022-35649GHSA-xp2f-9mx3-3c6p

Code injection in Moodle

Priority MEDIUM 53CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Why it matters now

EPSS 0.08554 95th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.9.15, 3.11.8, 4.0.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—MoodleFixed in moodle 4.0.2, moodle 3.11.8, moodle 3.9.15—No fix listedCNA
—moodle/moodle (Packagist)3.9 to before 3.9.153.9.15Patch availableGHSA-xp2f-9mx3-3c6p
—moodle/moodle (Packagist)3.11 to before 3.11.83.11.8Patch availableGHSA-xp2f-9mx3-3c6p
—moodle/moodle (Packagist)4.0 to before 4.0.24.0.2Patch availableGHSA-xp2f-9mx3-3c6p
  • Moodle Vendor— Affected Fixed in moodle 4.0.2, moodle 3.11.8, moodle 3.9.15 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.15 Fixed in 3.9.15 Patch available GHSA-xp2f-9mx3-3c6p
  • moodle/moodle (Packagist) Vendor— Affected 3.11 to before 3.11.8 Fixed in 3.11.8 Patch available GHSA-xp2f-9mx3-3c6p
  • moodle/moodle (Packagist) Vendor— Affected 4.0 to before 4.0.2 Fixed in 4.0.2 Patch available GHSA-xp2f-9mx3-3c6p

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*3.9.0 to before 3.9.15; 3.11.0 to before 3.11.8; 4.0.0 to before 4.0.2VulnerableMoodle
cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:*35VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:*36VulnerableFedoraproject
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.9.0 to before 3.9.15; 3.11.0 to before 3.11.8; 4.0.0 to before 4.0.2 Vulnerable ·Moodle
  • cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject

Remediation

  • Fix · GHSA-xp2f-9mx3-3c6p moodle/moodle (Packagist) Fixed in 3.9.15 Advisory →
  • Fix · GHSA-xp2f-9mx3-3c6p moodle/moodle (Packagist) Fixed in 3.11.8 Advisory →
  • Fix · GHSA-xp2f-9mx3-3c6p moodle/moodle (Packagist) Fixed in 4.0.2 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-35649
  2. 2026-10-03 Alias added: GHSA-xp2f-9mx3-3c6p
  3. 2026-10-09 EPSS moved to the 95th–99th percentile
  4. 2026-10-12 EPSS moved to the 90th–95th percentile
  5. 2026-10-16 EPSS moved to the 95th–99th percentile

References

Sources