Open redirect in Moodle
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-601.
Summary
An open redirect issue was found in Moodle due to improper sanitization of user-supplied data in mobile auto-login feature. A remote attacker can create a link that leads to a trusted website, however, when clicked, it redirects the victims to arbitrary URL/domain. Successful exploitation of this vulnerability may allow a remote attacker to perform a phishing attack and steal potentially sensitive information.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Moodle | Fixed in moodle 4.0.2, moodle 3.11.8, moodle 3.9.15 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 4.0 to before 4.0.2 | 4.0.2 | Patch available | GHSA-243v-5pff-qqfj |
| — | moodle/moodle (Packagist) | 3.11 to before 3.11.8 | 3.11.8 | Patch available | GHSA-243v-5pff-qqfj |
| — | moodle/moodle (Packagist) | 3.9 to before 3.9.15 | 3.9.15 | Patch available | GHSA-243v-5pff-qqfj |
- Moodle Vendor— Affected Fixed in moodle 4.0.2, moodle 3.11.8, moodle 3.9.15 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 4.0 to before 4.0.2 Fixed in 4.0.2 Patch available GHSA-243v-5pff-qqfj
- moodle/moodle (Packagist) Vendor— Affected 3.11 to before 3.11.8 Fixed in 3.11.8 Patch available GHSA-243v-5pff-qqfj
- moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.15 Fixed in 3.9.15 Patch available GHSA-243v-5pff-qqfj
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 3.9.0 to before 3.9.15; 3.11.0 to before 3.11.8; 4.0.0 to before 4.0.2 | Vulnerable | Moodle |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* | 36 | Vulnerable | Fedoraproject |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.9.0 to before 3.9.15; 3.11.0 to before 3.11.8; 4.0.0 to before 4.0.2 Vulnerable ·Moodle
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-243v-5pff-qqfj moodle/moodle (Packagist) Fixed in 4.0.2 Advisory →
- Fix · GHSA-243v-5pff-qqfj moodle/moodle (Packagist) Fixed in 3.11.8 Advisory →
- Fix · GHSA-243v-5pff-qqfj moodle/moodle (Packagist) Fixed in 3.9.15 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Moodle — FEDORA-2022-81ce74b2dd
5 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2022-16116 Path traversal in MoodlePriority HIGH 65
- TI-2022-16115 Code injection in MoodlePriority MEDIUM 53
- TI-2022-16119 Cross-site scripting in MoodlePriority LOW 35
- Advisory ·
Moodle — FEDORA-2022-7e7ce7df2e
5 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2022-16116 Path traversal in MoodlePriority HIGH 65
- TI-2022-16115 Code injection in MoodlePriority MEDIUM 53
- TI-2022-16119 Cross-site scripting in MoodlePriority LOW 35
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-35652
- 2026-10-03 Alias added: GHSA-243v-5pff-qqfj
References
Advisory 6
Sources
- CVE-2022-35652 · CVE Program
- CVE-2022-35652 · NVD
- FIRST EPSS
- GHSA-243v-5pff-qqfj · GitHub Advisory Database · CC BY 4.0
- CVE-2022-35652 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences