WordPress Awesome Support plugin <= 6.0.7 - Multiple Authenticated Persistent XSS (Additional Interested Parties)
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Multiple Authenticated (custom specific plugin role) Persistent Cross-Site Scripting (XSS) vulnerability in Awesome Support plugin <= 6.0.7 at WordPress.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00582 48th percentileScored 2026-11-07
Fix Fixed awesome-support/awesome-support (Packagist): 6.0.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Awesome Support Team | Awesome Support (WordPress plugin) | <= 6.0.7 – 6.0.7 | — | No fix listed | CNA |
| — | awesome-support/awesome-support (Packagist) | before 6.0.8 | 6.0.8 | Patch available | GHSA-qrqm-574x-q7f2 |
- Awesome Support (WordPress plugin) VendorAwesome Support Team Affected <= 6.0.7 – 6.0.7 Fixed in — No fix listed CNA
- awesome-support/awesome-support (Packagist) Vendor— Affected before 6.0.8 Fixed in 6.0.8 Patch available GHSA-qrqm-574x-q7f2
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:getawesomesupport:awesome_support:*:*:*:*:*:wordpress:*:* | up to 6.0.7 | Vulnerable | Awesome Support Team |
- cpe:2.3:a:getawesomesupport:awesome_support:*:*:*:*:*:wordpress:*:* Versions up to 6.0.7 Vulnerable ·Awesome Support Team
Remediation
- Fix · GHSA-qrqm-574x-q7f2 awesome-support/awesome-support (Packagist) Fixed in 6.0.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-38073
- 2026-10-03 Alias added: GHSA-qrqm-574x-q7f2
References
Advisory 2
Other 4
- https://wordpress.org/plugins/awesome-support/#developers
- https://github.com/Awesome-Support/Awesome-Support/commit/85f460be88b81fbdd9a990f474a1252297902faf
- https://github.com/Awesome-Support/Awesome-Support/commit/b2e831d7f831a3869cfd83eb79a398a5b5c0ec63
- https://github.com/Awesome-Support/Awesome-Support
More Awesome Support Team Awesome Support vulnerabilities
- TI-2023-04928 Awesome Support < 6.1.5 - Submitter+ Arbitrary File Deletion CVSS 3.1HIGH 8.1
- TI-2022-03239 Awesome Support < 6.1.2 - Subscriber+ Arbitrary Exported Tickets Download CVSS 3.1MEDIUM 6.5
- TI-2023-04927 Awesome Support < 6.1.5 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2023-04925 Awesome Support < 6.1.5 - Insufficient permission check in wpas_edit_reply CVSS 3.1MEDIUM 4.3
- TI-2024-20263 WordPress Awesome Support plugin <= 6.1.7 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-00550 Awesome Support – WordPress HelpDesk & Support Plugin <= 6.1.7 - Authenticated (Subscriber+) SQL Injection CVSS 3.1HIGH 8.8
Sources
- CVE-2022-38073 · CVE Program
- CVE-2022-38073 · NVD
- FIRST EPSS
- GHSA-qrqm-574x-q7f2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences