Metabase vulnerable to arbitrary SQL execution from queryhash
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Metabase is data visualization software. Prior to versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9, unsaved SQL queries are auto-executed, which could pose a possible attack vector. This issue is patched in versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9. Metabase no longer automatically executes ad-hoc native queries. Now the native editor shows the query and gives the user the option to manually run the query if they want.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Metabase | metabase | before 0.41.9; 0.42.0 to before 0.42.6; 0.43.0 to before 0.43.7; 0.44.0 to before 0.44.5; 1.0.0 to before 1.41.9; 1.42.0 to before 1.42.6; 1.43.0 to before 1.43.7; 1.44.0 to before 1.44.5 | 0.41.9, 0.42.6, 0.43.7, 0.44.5, 1.41.9, 1.42.6, 1.43.7, 1.44.5 | Patch available | CNA |
- metabase VendorMetabase Affected before 0.41.9; 0.42.0 to before 0.42.6; 0.43.0 to before 0.43.7; 0.44.0 to before 0.44.5; 1.0.0 to before 1.41.9; 1.42.0 to before 1.42.6; 1.43.0 to before 1.43.7; 1.44.0 to before 1.44.5 Fixed in 0.41.9, 0.42.6, 0.43.7, 0.44.5, 1.41.9, 1.42.6, 1.43.7, 1.44.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:metabase:metabase:*:*:*:*:*:*:*:* | 0.41.0 to before 0.41.9; 0.42.0 to before 0.42.6; 0.43.0 to before 0.43.7; 0.44.0 to before 0.44.5; 1.41.0 to before 1.41.9; 1.42.0 to before 1.42.6; 1.43.0 to before 1.43.7; 1.44.0 to before 1.44.5 | Vulnerable | Metabase |
- cpe:2.3:a:metabase:metabase:*:*:*:*:*:*:*:* Versions 0.41.0 to before 0.41.9; 0.42.0 to before 0.42.6; 0.43.0 to before 0.43.7; 0.44.0 to before 0.44.5; 1.41.0 to before 1.41.9; 1.42.0 to before 1.42.6; 1.43.0 to before 1.43.7; 1.44.0 to before 1.44.5 Vulnerable ·Metabase
Remediation
- Fix · CNA metabase (metabase) Fixed in 0.41.9, 0.42.6, 0.43.7, 0.44.5, 1.41.9, 1.42.6, 1.43.7, 1.44.5
Timeline
- 2026-10-02 Threatist record created from CVE-2022-39362
References
More Metabase vulnerabilities
- TI-2026-51115 Metabase SQL injection via password reset endpoint KEVCVSS 4.0CRITICAL 10.0
- TI-2021-18109 GeoJSON URL validation can expose server files and environment variables to unauthorized users KEVCVSS 3.1CRITICAL 10.0
- TI-2023-20003 Metabase open source before 0.46.6.1 and Metabase Enterprise before 1.46.6.1 allow… CVSS 3.1CRITICAL 9.8
- TI-2022-08664 File system exposure in Metabase CVSS 3.1MEDIUM 5.9
- TI-2025-05321 Metabase dom.js parseDataUri redos CVSS 4.0MEDIUM 5.3
- TI-2023-19078 Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint CVSS 3.1CRITICAL 10.0
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences