Cross-site request forgery in Jenkins Pipeline: Input Step Plugin
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 4 fixed, 1 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-352.
Summary
Jenkins Pipeline: Input Step Plugin 451.vf1a_a_4f405289 and earlier does not restrict or sanitize the optionally specified ID of the 'input' step, which is used for the URLs that process user interactions for the given 'input' step (proceed or abort) and is not correctly encoded, allowing attackers able to configure Pipelines to have Jenkins build URLs from 'input' step IDs that would bypass the CSRF protection of any target URL in Jenkins when the 'input' step is interacted with.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Pipeline: Input Step Plugin | up to 451.vf1a_a_4f405289 | 449.451.v9c3d42f23975 | Patch available | CNA |
| — | org.jenkins-ci.plugins:pipeline-input-step (Maven) | before 456.vd8a_957db_5b_e9 | 456.vd8a_957db_5b_e9 | Patch available | GHSA-g66m-fqxf-3w35 |
- Jenkins Pipeline: Input Step Plugin VendorJenkins Affected up to 451.vf1a_a_4f405289 Fixed in 449.451.v9c3d42f23975 Patch available CNA
- org.jenkins-ci.plugins:pipeline-input-step (Maven) Vendor— Affected before 456.vd8a_957db_5b_e9 Fixed in 456.vd8a_957db_5b_e9 Patch available GHSA-g66m-fqxf-3w35
Remediation
- Fix · CNA Jenkins Pipeline: Input Step Plugin (Jenkins project) Fixed in 449.451.v9c3d42f23975
- Fix · GHSA-g66m-fqxf-3w35 org.jenkins-ci.plugins:pipeline-input-step (Maven) Fixed in 456.vd8a_957db_5b_e9 Advisory →
Red Hat 4 advisories
- RHSA-2023:3198 Released 2023-05-17 · Red Hat rating Criticaljenkins and jenkins-2-plugins security update
- OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8 jenkins-2-plugins-4.11.1683009941-1.el8, jenkins-2.387.1.1683009763-3.el8
- RHSA-2023:1064 Released 2023-03-06 · Red Hat rating CriticalOpenShift Developer Tools and Services for OCP 4.12 security update
- OpenShift Developer Tools and Services for OCP 4.12 jenkins-2-plugins-4.12.1675702407-1.el8
- RHSA-2023:0777 Released 2023-02-23 · Red Hat rating CriticalOpenShift Container Platform 4.9.56 security update
- Red Hat OpenShift Container Platform 4.9 jenkins-2-plugins-4.9.1675668922-1.el8, jenkins-2.361.1.1675668150-1.el8
Show 1 more Red Hat advisories
- RHSA-2023:0560 Released 2023-02-08 · Red Hat rating CriticalOpenShift Container Platform 4.10.51 security update
- Red Hat OpenShift Container Platform 4.10 jenkins-2-plugins-4.10.1675144701-1.el8
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Out of support scope |
| OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8 | Fixed | RHSA-2023:3198 |
| OpenShift Developer Tools and Services for OCP 4.12 | Fixed | RHSA-2023:1064 |
| Red Hat OpenShift Container Platform 4.10 | Fixed | RHSA-2023:0560 |
| Red Hat OpenShift Container Platform 4.9 | Fixed | RHSA-2023:0777 |
Not affected: 4 products
- OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8
- OpenShift Developer Tools and Services for OCP 4.12
- Red Hat OpenShift Container Platform 4.10
- Red Hat OpenShift Container Platform 4.9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-43407
- 2026-10-03 Alias added: GHSA-g66m-fqxf-3w35
References
Advisory 3
More Jenkins Pipeline vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15846 A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.61 and earlier in… CVSS 3.1HIGH 8.8
- TI-2019-15847 A sandbox bypass vulnerability exists in Pipeline: Declarative Plugin 1.3.3 and earlier… CVSS 3.1HIGH 8.8
- TI-2023-11034 Cross-site scripting in Jenkins Pipeline: Build Step Plugin CVSS 3.1MEDIUM 5.4
- TI-2019-15886 A sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin 2.64 and earlier allows… CVSS 3.1CRITICAL 9.8
- TI-2022-21197 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-43407 · CVE Program
- CVE-2022-43407 · NVD
- FIRST EPSS
- GHSA-g66m-fqxf-3w35 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-43407 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences