Cross-site scripting in Jenkins Pipeline: Supporting APIs Plugin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 4 fixed, 1 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Jenkins Pipeline: Supporting APIs Plugin 838.va_3a_087b_4055b and earlier does not sanitize or properly encode URLs of hyperlinks sending POST requests in build logs, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to create Pipelines.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Pipeline: Supporting APIs Plugin | up to 838.va_3a_087b_4055b | 827.829.v01c0a_3d76c4f | Patch available | CNA |
| — | org.jenkins-ci.plugins.workflow:workflow-support (Maven) | before 839.v35e2736cfd5c | 839.v35e2736cfd5c | Patch available | GHSA-64r9-x74q-wxmh |
- Jenkins Pipeline: Supporting APIs Plugin VendorJenkins Affected up to 838.va_3a_087b_4055b Fixed in 827.829.v01c0a_3d76c4f Patch available CNA
- org.jenkins-ci.plugins.workflow:workflow-support (Maven) Vendor— Affected before 839.v35e2736cfd5c Fixed in 839.v35e2736cfd5c Patch available GHSA-64r9-x74q-wxmh
Remediation
- Fix · CNA Jenkins Pipeline: Supporting APIs Plugin (Jenkins project) Fixed in 827.829.v01c0a_3d76c4f
- Fix · GHSA-64r9-x74q-wxmh org.jenkins-ci.plugins.workflow:workflow-support (Maven) Fixed in 839.v35e2736cfd5c Advisory →
Red Hat 4 advisories
- RHSA-2023:3198 Released 2023-05-17 · Red Hat rating Criticaljenkins and jenkins-2-plugins security update
- OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8 jenkins-2-plugins-4.11.1683009941-1.el8, jenkins-2.387.1.1683009763-3.el8
- RHSA-2023:1064 Released 2023-03-06 · Red Hat rating CriticalOpenShift Developer Tools and Services for OCP 4.12 security update
- OpenShift Developer Tools and Services for OCP 4.12 jenkins-2-plugins-4.12.1675702407-1.el8
- RHSA-2023:0777 Released 2023-02-23 · Red Hat rating CriticalOpenShift Container Platform 4.9.56 security update
- Red Hat OpenShift Container Platform 4.9 jenkins-2-plugins-4.9.1675668922-1.el8, jenkins-2.361.1.1675668150-1.el8
Show 1 more Red Hat advisories
- RHSA-2023:0560 Released 2023-02-08 · Red Hat rating CriticalOpenShift Container Platform 4.10.51 security update
- Red Hat OpenShift Container Platform 4.10 jenkins-2-plugins-4.10.1675144701-1.el8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Out of support scope |
| OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8 | Fixed | RHSA-2023:3198 |
| OpenShift Developer Tools and Services for OCP 4.12 | Fixed | RHSA-2023:1064 |
| Red Hat OpenShift Container Platform 4.10 | Fixed | RHSA-2023:0560 |
| Red Hat OpenShift Container Platform 4.9 | Fixed | RHSA-2023:0777 |
Not affected: 4 products
- OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8
- OpenShift Developer Tools and Services for OCP 4.12
- Red Hat OpenShift Container Platform 4.10
- Red Hat OpenShift Container Platform 4.9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-43409
- 2026-10-03 Alias added: GHSA-64r9-x74q-wxmh
References
Advisory 3
More Jenkins Pipeline vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15846 A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.61 and earlier in… CVSS 3.1HIGH 8.8
- TI-2019-15847 A sandbox bypass vulnerability exists in Pipeline: Declarative Plugin 1.3.3 and earlier… CVSS 3.1HIGH 8.8
- TI-2023-11034 Cross-site scripting in Jenkins Pipeline: Build Step Plugin CVSS 3.1MEDIUM 5.4
- TI-2019-15886 A sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin 2.64 and earlier allows… CVSS 3.1CRITICAL 9.8
- TI-2022-21197 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-43409 · CVE Program
- CVE-2022-43409 · NVD
- FIRST EPSS
- GHSA-64r9-x74q-wxmh · GitHub Advisory Database · CC BY 4.0
- CVE-2022-43409 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences