Server-side request forgery in Metabase
Priority LOW 30CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-918 and the CVSS impact.
Summary
The url parameter of the /api/geojson endpoint in Metabase versions <44.5 can be used to perform Server Side Request Forgery attacks. Previously implemented blacklists could be circumvented by leveraging 301 and 302 redirects.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00798 56th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Metabase: 44.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Metabase | before 44.5 | 44.5 | Patch available | CNA |
- Metabase Vendor— Affected before 44.5 Fixed in 44.5 Patch available CNA
Remediation
- Fix · CNA Metabase Fixed in 44.5
Timeline
- 2026-10-02 Threatist record created from CVE-2022-43776
- 2026-10-03 Alias added: GHSA-mppc-g8x5-rq8c
References
More Metabase vulnerabilities
- TI-2026-51115 Metabase SQL injection via password reset endpoint KEVCVSS 4.0CRITICAL 10.0
- TI-2021-18109 GeoJSON URL validation can expose server files and environment variables to unauthorized users KEVCVSS 3.1CRITICAL 10.0
- TI-2023-20003 Metabase open source before 0.46.6.1 and Metabase Enterprise before 1.46.6.1 allow… CVSS 3.1CRITICAL 9.8
- TI-2022-08664 File system exposure in Metabase CVSS 3.1MEDIUM 5.9
- TI-2025-05321 Metabase dom.js parseDataUri redos CVSS 4.0MEDIUM 5.3
- TI-2023-19078 Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint CVSS 3.1CRITICAL 10.0
Sources
- CVE-2022-43776 · CVE Program
- CVE-2022-43776 · NVD
- FIRST EPSS
- GHSA-mppc-g8x5-rq8c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences