Ajax Search Lite < 4.11.1, Pro < 4.26.2 - Reflected Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Ajax Search Lite WordPress plugin before 4.11.1, Ajax Search Pro WordPress plugin before 4.26.2 does not sanitise and escape a parameter before outputting it back in a response of an AJAX action, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Ajax Search Lite | before 4.11.1 | 4.11.1 | Patch available | CNA |
| Unknown | Ajax Search Pro | before 4.26.2 | 4.26.2 | Patch available | CNA |
- Ajax Search Lite VendorUnknown Affected before 4.11.1 Fixed in 4.11.1 Patch available CNA
- Ajax Search Pro VendorUnknown Affected before 4.26.2 Fixed in 4.26.2 Patch available CNA
Remediation
- Fix · CNA Ajax Search Lite (Unknown) Fixed in 4.11.1
- Fix · CNA Ajax Search Pro (Unknown) Fixed in 4.26.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Ajax Search Pro 4.26.2
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2023-01355 Ajax Search Lite Pro < 4.26.2 - Multiple Reflected Cross-Site ScriptingPriority MEDIUM 60
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1420
- 2026-10-03 Alias added: GHSA-cq3h-xfg9-7523
References
More wpdreams Ajax Search vulnerabilities
- TI-2023-01355 Ajax Search Lite Pro < 4.26.2 - Multiple Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2024-09790 Ajax Search Lite < 4.12.4 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.7
- TI-2024-07995 Ajax Search Lite <= 4.12.2 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-06563 Ajax Search Lite < 4.12.1 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-12626 Ajax Search Lite < 4.12.5 - Admin+ Stored XSS CVSS 3.1LOW 3.5
- TI-2024-14438 WordPress Ajax Search Lite Plugin <= 4.11.4 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
Sources
- CVE-2023-1420 · CVE Program
- CVE-2023-1420 · NVD
- FIRST EPSS
- GHSA-cq3h-xfg9-7523 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences