Read the docs
TI-2024-12626 Aliases CVE-2024-13585GHSA-jfh6-m8fx-jjp9

Ajax Search Lite < 4.12.5 - Admin+ Stored XSS

Priority MEDIUM 50CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Ajax Search Lite WordPress plugin before 4.12.5 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00412 35th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Ajax Search Lite (Unknown): 4.12.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownAjax Search Litebefore 4.12.54.12.5Patch availableCNA
  • Ajax Search Lite VendorUnknown Affected before 4.12.5 Fixed in 4.12.5 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wp-dreams:ajax_search:*:*:*:*:lite:wordpress:*:*before 4.12.5Vulnerablewpdreams
  • cpe:2.3:a:wp-dreams:ajax_search:*:*:*:*:lite:wordpress:*:* Versions before 4.12.5 Vulnerable ·wpdreams

Remediation

  • Fix · CNA Ajax Search Lite (Unknown) Fixed in 4.12.5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-13585
  2. 2026-10-03 Alias added: GHSA-jfh6-m8fx-jjp9

References

  • TI-2023-01355 Ajax Search Lite Pro < 4.26.2 - Multiple Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
  • TI-2023-01343 Ajax Search Lite < 4.11.1, Pro < 4.26.2 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
  • TI-2024-09790 Ajax Search Lite < 4.12.4 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.7
  • TI-2024-07995 Ajax Search Lite <= 4.12.2 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2024-06563 Ajax Search Lite < 4.12.1 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2024-14438 WordPress Ajax Search Lite Plugin <= 4.11.4 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1

Sources