Ajax Search Lite < 4.12.1 - Admin+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Ajax Search Lite WordPress plugin before 4.12.1 does not sanitise and escape some parameters, which could allow users with a role as low as Admin+ to perform Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00389 33rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Ajax Search Lite (Unknown): 4.12.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Ajax Search Lite | before 4.12.1 | 4.12.1 | Patch available | CNA |
- Ajax Search Lite VendorUnknown Affected before 4.12.1 Fixed in 4.12.1 Patch available CNA
Remediation
- Fix · CNA Ajax Search Lite (Unknown) Fixed in 4.12.1
Timeline
- 2026-10-02 Threatist record created from CVE-2024-7084
- 2026-10-03 Alias added: GHSA-fj5p-6c44-4pp3
References
More wpdreams Ajax Search vulnerabilities
- TI-2023-01355 Ajax Search Lite Pro < 4.26.2 - Multiple Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2023-01343 Ajax Search Lite < 4.11.1, Pro < 4.26.2 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2024-09790 Ajax Search Lite < 4.12.4 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.7
- TI-2024-07995 Ajax Search Lite <= 4.12.2 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-12626 Ajax Search Lite < 4.12.5 - Admin+ Stored XSS CVSS 3.1LOW 3.5
- TI-2024-14438 WordPress Ajax Search Lite Plugin <= 4.11.4 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
Sources
- CVE-2024-7084 · CVE Program
- CVE-2024-7084 · NVD
- FIRST EPSS
- GHSA-fj5p-6c44-4pp3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences