SupportCandy < 3.1.7 - Admin+ SQLi
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The SupportCandy WordPress plugin before 3.1.7 does not properly sanitise and escape the agents[] parameter in the set_add_agent_leaves AJAX function before using it in a SQL statement, leading to a SQL injection exploitable by high privilege users such as admin.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | SupportCandy | before 3.1.7 | 3.1.7 | Patch available | CNA |
- SupportCandy VendorUnknown Affected before 3.1.7 Fixed in 3.1.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:supportcandy:supportcandy:*:*:*:*:*:wordpress:*:* | before 3.1.7 | Vulnerable | SupportCandy |
- cpe:2.3:a:supportcandy:supportcandy:*:*:*:*:*:wordpress:*:* Versions before 3.1.7 Vulnerable ·SupportCandy
Remediation
- Fix · CNA SupportCandy (Unknown) Fixed in 3.1.7
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
SupportCandy 3.1.7
2 records Highest priority Priority HIGH 2 HIGH
Other records, highest priority first
- TI-2023-02547 SupportCandy < 3.1.7 - Subscriber+ SQLiPriority HIGH 73
Timeline
- 2026-10-02 Threatist record created from CVE-2023-2805
- 2026-10-03 Alias added: GHSA-433m-h5jj-8j5m
References
More Supportcandy vulnerabilities
- TI-2023-01623 SupportCandy < 3.1.5 - Unauthenticated SQLi CVSS 3.1CRITICAL 9.8
- TI-2023-02547 SupportCandy < 3.1.7 - Subscriber+ SQLi CVSS 3.1HIGH 8.8
- TI-2019-08400 An Unrestricted File Upload Vulnerability in the SupportCandy plugin through 2.0.0 for… CVSS 3.0CRITICAL 9.8
- TI-2021-07161 SupportCandy < 2.2.7 - CSRF to Cross-Site Scripting CVSS 3.1HIGH 8.8
- TI-2021-07121 SupportCandy < 2.2.5 - Unauthenticated Arbitrary Ticket Deletion CVSS 3.1HIGH 7.5
- TI-2021-07160 SupportCandy < 2.2.7 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-2805 · CVE Program
- CVE-2023-2805 · NVD
- FIRST EPSS
- GHSA-433m-h5jj-8j5m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences