tagDiv Composer < 4.2 - Admin+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The tagDiv Composer WordPress plugin before 4.2, used as a companion by the Newspaper and Newsmag themes from tagDiv, does not validate and escape some settings, which could allow users with Admin privileges to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | tagDiv Composer | before 4.2 | 4.2 | Patch available | CNA |
- tagDiv Composer VendorUnknown Affected before 4.2 Fixed in 4.2 Patch available CNA
Remediation
- Fix · CNA tagDiv Composer (Unknown) Fixed in 4.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
tagDiv Composer 4.2
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2023-02969 tagDiv Composer < 4.2 - Unauthenticated Stored XSSPriority MEDIUM 60
Timeline
- 2026-10-02 Threatist record created from CVE-2023-3170
- 2026-10-03 Alias added: GHSA-7578-qrmf-q6j6
References
More Tagdiv Composer vulnerabilities
- TI-2023-02969 tagDiv Composer < 4.2 - Unauthenticated Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2024-03557 tagDiv Composer <= 4.8 - Authenticated (Contributor+) Local File Inclusion via Shortcode CVSS 3.1HIGH 8.8
- TI-2023-20332 WordPress tagDiv Composer Plugin < 4.4 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 7.1
- TI-2024-04837 tagDiv Composer <= 5.0 - Reflected Cross-Site Scripting via envato_code[] CVSS 3.1MEDIUM 6.1
- TI-2024-03626 tagDiv Composer <= 5.0 - Reflected Cross-Site Scripting via envato_code[] CVSS 3.1MEDIUM 6.1
- TI-2025-02450 tagDiv Composer <= 5.3 - Reflected Cross-Site Scripting via 'data' CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-3170 · CVE Program
- CVE-2023-3170 · NVD
- FIRST EPSS
- GHSA-7578-qrmf-q6j6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences