PostX < 4.0.2 - Contributor+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Post Grid Gutenberg Blocks and WordPress Blog Plugin WordPress plugin before 4.0.2 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Post Grid Gutenberg Blocks and WordPress Blog Plugin | before 4.0.2 | 4.0.2 | Patch available | CNA |
- Post Grid Gutenberg Blocks and WordPress Blog Plugin VendorUnknown Affected before 4.0.2 Fixed in 4.0.2 Patch available CNA
Remediation
- Fix · CNA Post Grid Gutenberg Blocks and WordPress Blog Plugin (Unknown) Fixed in 4.0.2
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3239
- 2026-10-03 Alias added: GHSA-928w-mwq7-xvqr
References
More wpxpo Postx vulnerabilities
- TI-2024-09942 PostX <= 4.1.16 - Missing Authorization to Arbitrary Plugin Installation/Activation CVSS 3.1HIGH 8.8
- TI-2024-04008 PostX < 4.1.0 - Contributor+ Stored XSS CVSS 3.1MEDIUM 6.8
- TI-2023-03707 PostX - Gutenberg Post Grid Blocks < 3.0.6 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2024-20622 WordPress PostX plugin <= 3.2.3 - Author+ Post/Page Duplication vulnerability CVSS 3.1HIGH 8.8
- TI-2023-18248 WordPress PostX – Gutenberg Blocks for Post Grid Plugin <= 2.9.9 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2024-33876 WordPress PostX plugin <= 4.1.12 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-3239 · CVE Program
- CVE-2024-3239 · NVD
- FIRST EPSS
- GHSA-928w-mwq7-xvqr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences