LearnPress < 4.2.5.5 - Reflected Cross-Site Scripting
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The LearnPress WordPress plugin before 4.2.5.5 does not sanitise and escape user input before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00908 60th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed LearnPress (Unknown): 4.2.5.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | LearnPress | before 4.2.5.5 | 4.2.5.5 | Patch available | CNA |
- LearnPress VendorUnknown Affected before 4.2.5.5 Fixed in 4.2.5.5 Patch available CNA
Remediation
- Fix · CNA LearnPress (Unknown) Fixed in 4.2.5.5
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5558
- 2026-10-03 Alias added: GHSA-mj4q-j8hp-mw73
References
More ThimPress Learnpress vulnerabilities
- TI-2024-07900 LearnPress – WordPress LMS Plugin <= 4.2.7 - Unauthenticated SQL Injection via 'c_only_fields' CVSS 3.1CRITICAL 10.0
- TI-2023-06018 LearnPress <= 4.2.5.7 - Unauthenticated SQL Injection via order_by CVSS 3.1CRITICAL 9.8
- TI-2024-04124 LearnPress – WordPress LMS Plugin <= 4.2.6.5 - Unauthenticated Time-Based SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2023-18355 WordPress LearnPress plugin <= 4.2.3 - Authenticated Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2022-03105 LearnPress < 4.1.7.2 - Unauthenticated PHP Object Injection via REST API CVSS 3.1HIGH 8.1
- TI-2020-04911 LearnPress Wordpress plugin version prior and including 3.2.6.7 is vulnerable to SQL Injection CVSS 3.1HIGH 8.8
Sources
- CVE-2023-5558 · CVE Program
- CVE-2023-5558 · NVD
- FIRST EPSS
- GHSA-mj4q-j8hp-mw73 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences