JobSearch WP Job Board < 2.3.4 - Arbitrary File Upload to RCE
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The WP JobSearch WordPress plugin before 2.3.4 does not validate files to be uploaded, which could allow unauthenticated attackers to upload arbitrary files such as PHP on the server
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP JobSearch | before 2.3.4 | 2.3.4 | Patch available | CNA |
- WP JobSearch VendorUnknown Affected before 2.3.4 Fixed in 2.3.4 Patch available CNA
Remediation
- Fix · CNA WP JobSearch (Unknown) Fixed in 2.3.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
WP JobSearch 2.3.4
2 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM
Other records, highest priority first
- TI-2023-06035 JobSearch WP Job Board < 2.3.4 - Authentication BypassPriority MEDIUM 40
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6585
- 2026-10-03 Alias added: GHSA-q25f-2gjj-7ppp
References
More eyecix Jobsearch Wp Job Board vulnerabilities
- TI-2024-07991 WP JobSearch <= 2.6.7 - Unauthenticated Arbitrary File Upload CVSS 3.1CRITICAL 10.0
- TI-2024-07990 WP JobSearch <= 2.6.7 - Authenticated (Subscriber+) Arbitrary File Upload CVSS 3.1CRITICAL 9.9
- TI-2024-29520 WordPress JobSearch WP Job Board WordPress Plugin plugin <= 2.5.3 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-29518 WordPress JobSearch WP Job Board WordPress Plugin plugin <= 2.5.4 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-31915 WordPress WP JobSearch plugin <= 2.5.9 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2021-03218 JobSearch WP Job Board <= 1.8.1 - Missing Authorization to Arbitrary Options Update CVSS 3.1HIGH 8.8
Sources
- CVE-2023-6585 · CVE Program
- CVE-2023-6585 · NVD
- FIRST EPSS
- GHSA-q25f-2gjj-7ppp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences